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1. Introduction

This manual is divided into three sections. The first section is devoted to introducing
you to the List & Label Designer and the functions which are available to you.

The second section describes in turn the commands which are available via the menu.

In the appendix you will find a description of the functions which allow you to
manipulate strings and numbers.

But, to start, let's take a look at the layout and the individual tools.

1.1. The Designer Interface

A Rulers G Status Line M   Views
B Menubar H Preview Window
C Objectbar I Objects
D Toolbar J Layer Window
E Project Title & File Name K Context Menu
F Workspace L Variable List
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1.1.1. Rulers

The rulers form a frame around the workspace. The units used on the ruler
automatically adapt to the respective measuring mode that you have configured in
Windows. The current position of the mouse is shown as line markings on the rulers,
displaying the respective coordinates at any given time. These units correspond to the
default values in your Windows system control.

1.1.2. Object Bar

Some of the tools available in the Designer can be accessed via the button bar on the
left-hand-side of your workspace. With a mere button click you are offered a direct
short-cut option.

These buttons are self-explanatory: if you remain on the button for a while without
pressing a mouse key then a short description of the button function appears in a
small window. This bar can be placed/removed by choosing Options >Workspace
>Toolbar show "objects".

Tool Corresponding menu items

 Objects > Select

 Objects > Insert > Text

 Objects >Insert > Line

 Objects > Insert > Rectangle

 Objects > Insert > Ellipse / Circle

 

Objects > Insert > Picture

 Objects > Insert > Barcode

 Objects > Insert > Table

 Objects > Insert > Formatted Text

 Objects > Insert > Chart

 Objects > Insert > HTML Text

1.1.3. Toolbar

In the same manner, menu items, can also be directly selected via the toolbar (as a
short-cut). Just click on the button you require.

Tool Corresponding menu items

File > New

File > Open

File > Save

File > Print Sample

Edit > Cut

Edit > Insert
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Edit > Copy

Edit > Undo

Project > Page Setup

Objects > Properties

Objects > Arrange > To Front

Objects > Arrange > To Back

Objects > Arrange > Alignment > Left

Objects > Arrange > Alignment > Right

Objects > Arrange > Alignment > Top

Objects > Arrange > Alignment > Bottom

Objects > Arrange > Alignment > Size fit horizontal

Objects > Arrange > Alignment > Size fit vertical

Help

Context Sensitive Help

File > Exit

1.1.4. Context menu

The most important used commands that concern an object can be
activated via a context menu.

This function must be activated by choosing "Options >
Compatibility > Context menu".

1.1.5. Workspace

The workspace is the area in which objects can be changed and defined. The shape
and size of the workspace depends on the default values of the paper size and
alignment (see: Project > Page Setup).
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The entity of all objects on the workspace and its corresponding layout are called a
project. List & Label distinguishes between list projects (list/table creation), card and
label projects (label creation).

1.1.6. Preview

The preview window is available in order
for you to check the layout of your
workspace. Click in the window to
change between full size and normal
window size. The size of the preview
window can be changed by dragging
the frame. These settings are stored
globally for the project type, and are
therefore valid for all List & Label
projects of the same type.

You can select an area to enlarge by
dragging a rectangle. The zoom modes
in this preview are independant of the
zoom mode in the workspace.

With this button you increase the zoom factor of your current preview view by a
factor of 2.

This button reverts the last zoom change and restores your previous view.

Click this button to adapt the zoom factor in order to view the whole page.

1.1.7. Status Bar

The status bar is divided into three sections:
n the left area indicates the current mouse position in millimeters or inches from

the left upper workspace corner.
n the middle area indicates the current mode of operation. (for example,

selection, draw rectangle, etc.)
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n the right area shows the name or type, relative appearance level, as well as
the size of a selected object.

1.1.8. View Modes

At the bottom of the workspace you can select the view mode:

n In Layout mode you can see the object frames and the contents of the objects
as formula. This mode is ideal for exact positioning and is the fastest mode.

n Layout Preview mode shows the objects in WYSIWYG mode. If the system DLL
MSIMG32.DLL is present (normally from Windows 98 or Windows 2000
upwards) objects will be painted transparently in the layer color.

n The Preview mode is identically to the separate preview window. The separate
preview window is automatically closed when this mode is active. In the
contrast to the separate window, you can edit all objects.

1.1.9. Layer Window

The layer window shows the various layers or levels of a
project. This window can be repositioned on the
workspace at your will.

You can increase the overview in complex projects by
assigning objects to an individual layer. You can switch
layers on and off at any time by using the layer window.
You can give these layers their own appearance conditions.

For example, one layer may only be valid for the first page of a multi-page project,
and the second layer for the remaining pages.

More detailed information on working with layers can be found in chapter 2.6,
"Working With Layers".

1.1.10. Variable List

The variable list displays all variables which are available in the
current project; for list type projects, all available fields are
additionally displayed.

Fields, variables, and internal List & Label variables are
distinguished in the hierarchical list. Fields contain the data
changing from line to line of a table object, while variables
usually only change from page to page.

If you wish to assign variables or fields to existing objects, you
may simply drag the variable from the list and drop it on the

respective object. List & Label does the pasting for you (drag & drop).

If you drag a variable to a free area in the project workspace, a new text object is
automatically generated.
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1.1.11. Drag & Drop

The List & Label designer is equipped with a broad range of interesting drag & drop
functions, simplifying the project design process. It is possible (see above) to add new
contents to existing objects by drag & drop, or create new objects in a free area in the
project workspace. This system was also integrated into many dialogs: you may add
new contents to the property dialogs of text- and table objects or move existing
contents easily with the mouse.

1.2. Dialogs

The dialogs of the List & Label Designer are designed with recurring functions,
enabling you to quickly become familiar with the designer and work effectively. The
following list describes some buttons which will simplify your work in many dialogs:

Online-Help

The designer is supplied with context sensitive online-help, which can be
started from nearly all dialogs with this button. The online help describes the
dialogs and functions as detailed as this manual and may even replace it.

New

This Button is used to add new contents to a dialog, a new line in a text object,
for example.

Edit

This button is used to edit the contents or properties of the selected item(s).

Delete

This button deletes the selected item(s).

Cut

This button cuts the selected item(s) to the clipboard.

Copy

This button copies the selected item(s) to the clipboard.

Paste

This button pastes the item(s) from the clipboard to the current object.
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Move

With these buttons, the order of the selected item(s) can be changed.
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2. General Methods and Procedures

The List & Label Designer recognizes three types of projects - lists, labels, and cards
(often complex label projects).

The individual elements of a project are called "objects". In this manner, a label project
can, for example, consist of an object for the sender line, the address area, and the
logo.

These objects contain the information required for printing such as the actual
contents, fonts, alignments, word wrapping, colors, etc.

The List & Label Designer provides different types of objects which can be freely
placed and changed in size on your workspace. Depending on its type, an object can
display information or have various different properties.

 
Text
These objects can contain fixed text as well as the variable content of individual records.
You can determine the fonts, object orientation, and alignment of the contents.

 
Rectangles
These objects are rectangular frames for which layout options such as frame width,
colors, filling pattern and shading can be defined.

 
Circles and Ellipses
Define Circles and Ellipses. Layout options such as frame width, colors and filling pattern
can be defined.

 
Lines
With this object type you can define lines with layout options such as line width and
color.

 
Picture Files
These objects allow you to integrate graphics into projects. These can be either fixed
graphics (ex. a company logo) or variable graphics (i.e. different for each record).

 
Barcodes
These objects allow you to display fixed text or variable contents as barcodes. You can
define characteristics such as the type of barcode, color, text, and orientation.

 
Tables (Lists)
These objects allow you to display fixed text and variable contents from various records.
You can define layout characteristics such as appearance, fonts, column widths and
alignments, word wraps, footers, etc.

 
Formatted Text
With this object type you can change the format within a line.

 
Chart
With this object you can create diagrams.

 

HTML Text
With this object you can display the contents of web sites an other HTML formatted
text.

You normally position the required objects in the workspace with your mouse, and
then determine the corresponding contents and layout properties. Alternatively, you
can just drag a variable from the variable list per drag & drop, and place it on your
workspace.
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In order to edit an existing object you need to select it. Just click into the required
object. The object will be selected. A selected object can be identified by its frame.
When a new object is created, it is automatically "selected" and can be edited or
changed immediately.

The property dialog of an object can be activated with a double-click. Please be aware
that the selection tool has to be activated. See Chapter 1.1.3 "Object bar."

2.1. Projects

2.1.1. Creating or Opening a Project

Use the File menu commands to open existing projects in the List & Label Designer or
create new ones.

Create a new project

To start a new project, select File > New. If your current project has unsaved
changes, you will be asked whether you would like to save them. List & Label

then automatically opens the default project for the type of project you require.

Normally this is merely an empty workspace with a certain paper size and alignment.
In the case of label projects you can also pre-determine a certain label format (size
and the layout of individual labels on the page).

If you chose "New project assistant" in the Options > Workspace dialog, you will be
guided through the process of creating a new project by the project wizard (see
below).

Hint: A default project is a standard empty "copy" to aid in the creation of projects. It
is however possible for you to change the default project to your own requirements
and save it as a file called "default". The next time you call File > New your own -
changed - default project will be opened.

The Project Wizard

The project wizard will help you create new projects. In label / card projects you will
be first lead through the layout options. Afterwards you can choose a page title and a
matrix of text objects. In list projects you can set the layout options as well as:

n page numbering
n page title (first page only or all pages)
n zebra pattern for the table
n create a summary
n choose the data for the table object

Opening an Existing Project

To open an existing project select File > Open.

If a description has been given to a project (see File > Save As) the
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description will be displayed underneath the sketch field. In the "sketch" field you can
see a sketch of each selected project, making it easier for you to find the project you
are looking for. (The sketch is only shown if the corresponding option is set, see:
Options > Compatibility > Sketch in File Dialog).

If you open a project that was designed with an older version of List & Label Designer
List & Label will inform you. Please note that projects designed with the new Designer
will not be readable or editable with an older version. We advise you to make
backups of your project files before editing them with the new Designer. Please check
your layout after conversion carefully, as slight changes are possible.

2.1.2. Project Import

With the command File > Import you can insert all objects from another project
into the current project.

2.1.3. Project Types

The List & Label Designer is capable of different kinds of projects: labels, lists and
cards. Please note that it is not possible to switch between the different project types
in one designer session. The designer has to be closed and reopened in the new mode
for this purpose.

It is however possible to design multiple projects of the same type. Simply open or
create the objects in the order you want to design them. You may not open multiple
projects at one time, but you can copy objects from one project to another using the
clipboard.

2.2. Determining Page Setup

Before you start to place objects in a project, please choose your layout. With
the command Project > Page Setup you can determine properties such as

paper size and orientation. The layout options available depend on the type of project
you are currently working with.

2.2.1. Page Setup for Labels

In the page setup for labels you can set the paper size and orientation as well as the
printer via the printer setup. You can either open one of the predefined label formats
or define one of your own.

Selecting Printer and Paper Format

Click the "choice" button to determine the paper size and alignment and choose the
printer for the project.



List & Label - Designer General Methods and Procedures

16

You can also either open a
predefined label format, or freely
create your own. The paper
orientation is saved with the
project and does not change the
Windows default printer settings.

 If the project consists of only one
page or one printer specification
for all pages choose the "printer
page independent" button.

For projects with more than one
page it can be useful to choose a
different printer specification or
different printer. If you check the
"printer page dependent" option,

you can choose different printer (-options) for the first and the following pages. In
this way you can take corporate letter-head paper for the first page and normal paper
for the following pages.

Force Page Format(s) if possible

If no printer definition file exists and this option is set, the paper format
selected during design will be forced during print out. Prerequisite is that
the respective format or a "user defined" format is supported by the printer.
Else, the next size up will be chosen.

Use physical paper size and not only the printable area

If this option is set the whole physical page is available as workspace, including non-
printable margins. Some label page layouts require this, as the first label starts right
at the left top edge instead of at a specific distance. The unprintable margins are
shown shaded in the full-page preview.

This means that objects can also be placed in the margins which will be cut

off during the print. If objects are placed on page edges you still should

take notice of the unprintable area.
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Using Pre-Defined Label Formats

You can choose from a range of
pre-defined label formats in the
"templates" register in the page
setup for labels. Now you won't
have to find out the size of a
particular label and how many
labels are on one page.

Defining Your Own Label Formats

It is also possible to define your
own label layout if the one you
require is not available. Use the
following values:

Setting the Offset

The offset provides the horizontal
and/or vertical distance of the top
left-hand label to the edge of the
workspace (depending on the
"physical page size switch, this is
relative to the paper edge or the
printable area edge).

Hint: the top left corner of the
workspace always begins on the
screen display with the coordinate

0/0, independent of the chosen page size and offset. The effects of the offset can
however be seen in the full-page preview or when you print.

Setting the Size

This provides the size (horizontal = width / vertical = height) of the label in inch or
mm.



List & Label - Designer General Methods and Procedures

18

Setting the Distance

This option determines the distance from one label to the next (the space between
two labels). For labels with only one column, only the vertical distance needs to be
given.

Setting the Number

This option determines the number of labels per page. (horizontal value = number of
columns per page, vertical value = numbers of lines per page)

You can check the layout by selecting Options > Preview > Page Preview.

Determining Print Order

In addition to the printer and paper format, in a label project you can also determine
the print order of the labels on a label sheet. Labels are standardly printed in lines
from top left to bottom right. With partly used sheets of labels you may have already
used the first line of labels, for example, which could cause the sheet to lose its
stability at the top. Some printers have problems taking such sheets and react with a
paper jam.

Here you have the option of printing sheets of labels from the bottom up. In this way
the top line of labels will be printed last and the sheet remains stable, even when the
critical area on the sheet is reached.

Determining Export Media

On this tab you can specify which export target (Preview, HTML, RTF, PDF, XML,
Picture, available options may vary) should be used as default for the project.

2.2.2. Page Setup for Lists

You can determine the page setup for one of the printers you wish to use as well as
the paper size and alignment.

You can also determine whether the workspace should be displayed as a physical
page or only with the areas which are actually printed by the printer selected.

Selecting Printer and Paper Format

The remaining set up is done just as with labels.

2.3. Default Values and Options

Before you start to insert individual objects belonging to a project on your workspace,
and set their properties you need to define the default values you require with the
command Project > Options. In this way you'll save time and effort later on.

You can also call up this options dialog via the menu item Options.

Each option in this dialog is explained by a tooltip.



List & Label - Designer General Methods and Procedures

19

2.3.1. Options for a Project

The options set in the "Project" tab are only valid for your current project.

Defining Alignment Grid

Specify whether a grid net
should be placed in the
background of the
workspace or not. You can
set the distances of the
grid lines. The option
"horizontal - vertical -
synchronized" enables the
same grid distancing in
both directions.

With the option "Snap to
Grid" you ensure that
objects are not freely
inserted or moved on the
workspace but only along
the grid lines.

Precision

Here you can determine the default number of decimal places for numeric values,
which will be used as long as they aren't printed with format specifiers (ex. FStr$).

2.3.2. Options for Objects

Default values set on the tab "Objects" are valid for all new objects, until they are
changed.

With the tab "Objects" you can make various settings for objects. Newly created
objects have these default values to start off with. You can also change these values
afterwards individually for each object. We recommend setting these values to a
suitable level when beginning a new project so that the manual changes are kept
later on to a minimum.

The default values are only valid for the project currently open.

Object Font

In the "Object Font" group you can
determine the font for each newly
inserted object, using the "Select"
button.

These default values are only valid for
objects which contain text, in this case
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text objects and list objects. The settings also affect all objects which were not
changed manually to a non default style.

Object Colors

With the comboboxes "Border" and "Filling" you can set different colors for different
objects. These values are however only valid for the object types circle/ellipse,
rectangle, and line.

2.3.3. Options for the Preview

On the "Preview" tab you can determine global settings for the preview.

Setting Colors for the
Preview

In the "Colors" group you
can determine the color for
the background of the
preview window using the
combobox "Background".
With the combobox "Border"
you can select the color of
the simulated paper border
in the preview.

View of Label/Card
Projects

Here you can choose if the
preview should contain only

one label or the complete page (only available for label or card projects).

Optimized View

Using the options from the "View Optimization" group you can reduce different
preview details, which enables a faster preview.
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2.3.4. Options for the Workspace

Setting Rulers

In the "Ruler Colors"
group you can
define the
foreground and
background colors
for the rulers which
form a frame
around the
workspace.

Displaying
Objects

In the "Text in
Objects" group you
can determine
whether the text
contained in

objects should be displayed or not on the workspace. The "WYSIWYG"-option displays
the chosen fonts and formats the way they are printed.

Settings for Usability

The "Usability" options allow you to determine various default values for handling the
List & Label Designer.

n Check the option "Object Info" to get a tooltip with the object name.
n Check the option "New Project Wizard" to receive assistance when creating

new projects.
n If the option "Fast update" is checked objects will be painted faster. On some

systems  light flickering may occur.

Colored Table Areas

The designer can color the different areas of the selected table object for a better
overview. Prerequisite is the file MSIMG32.DLL, which is usually contained in the
operating system in Windows 98 and Windows 2000.

2.3.5. Compatibility Options

Here you can set various options which concern or are involved with other software
programs or hardware components.
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Clipboard Format is
Text

This option determines
the format in which
objects should be
copied to the clipboard
in the List & Label
Designer. This option
only takes effect when
pasting Designer objects
into other applications.

When the option is set,
the internal definition of
the object can be
inserted via the
clipboard into other
programs.

When the option is not set, List & Label uses its own clipboard format.

Sketch within File Dialog

This option determines whether a sketch of the currently selected project is shown in
the file selection dialog. When the option is set, a sketch will be created each time
you save the project. In this way it is easier to select the required project for editing or
printing.

Some very old graphic card drivers unfortunately have problems in the support of this
function. In this case it is helpful to switch off the option.

Compatibility with former Versions

The "Workspace" options allow to determine various default values.

n With the option "Context Menu" you can determine whether a right click on an
object opens a context menu, or whether the properties dialog should be
automatically opened.

n Set the "Enter selection mode after insertion of a new object" option in order
to switch to the selection mode automatically after inserting an object. This
prevents you ex. from inserting multiple objects accidentally.
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2.3.6. Options for the Formula Wizard

The formula wizard offers many enhancements for creating formulas or functions.
Here you can disable these enhancements.

n Show Function Syntax: a tooltip describing the function and parameters
appears.

n Autocomplete for Functions: after entering 2 characters all functions that fit
will be shown and can be selected.

n Autocomplete for Parameters: after entering 2 characters all parameters that
fit will be shown and can be selected.

n Syntax Coloring: functions, parameters and operators are displaed in different
colors.

n Automatic Type Conversion: variables and fields will be surrounded by
conversion functions to fit the context of the function.

2.4. Inserting Objects

In List & Label objects usually have a rectangular shape and are surrounded by a
frame in which their size and position can be changed. This frame indicates the area
which the object occupies in the workspace and consequently the maximal scope that
the contents of an object can have. Objects may, however, overlap slightly or fully
whereby the overlapped object may sometimes be concealed completely.

Objects may be inserted in the project workspace in different ways: using the menu
Object > Insert, the toolbar, shortcut keys or per drag & drop functionality of the
variable list. Text objects are inserted most comfortable and efficient per drag & drop
from the variable list. Simply choose the desired variable and drag it to a free area in
the project workspace. All other object types are inserted most easily via the toolbar.

n Choose the desired object type from the menu Objects > Insert, the toolbar, or
the shortcut keys.

n Select the rectangle the new object should occupy in the workspace.

You can alternatively, as described above, drap & drop the object from the variable
list.
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2.5. Editing Objects

Select the object you would like to edit. Then you can:

n change the size of the object and reposition it on the workspace.
n edit the contents (properties) of the object. These contents are different

according to the type of object selected (text, picture, table, etc.).
n determine the exact position of an object on the workspace via the position

dialog in 1/10 millimeter steps.
n define appearance conditions for the object. With an appearance condition

you determine the condition to be met for the object to be printed. In this
way you can allow a logo to appear on the first page of a project only and not
on the following pages.

n name the object. Using the name you can easily find the object you are
looking for.

n assign the object to a (display)-layer or copy it to a layer. Multipage and/or
complex projects become clearer if objects which belong together are put on a
mutual layer. So, in a multipage project all objects which belong to one page
can be put on a common layer. You only need to toggle the visibility of this
layer when you want to edit it.

n copy the object. If you want to place several, similar objects with the same
distance on the workspace then you can use the function Create Multiple
Copies.

n edit the object via the object list and link it with other objects. In this way you
can make sure that the position or size of an object is automatically adapted if
the position or size of the object it is linked to changes.

If you have selected more than one object you can combine the selected objects into
a group (grouping), align them or adapt their size.

These editing possibilities will now be described individually in detail.

2.5.1. Selecting Objects

You must be in selection mode before you can select an object. The currently active
mode is displayed in the middle area of the info bar. To change to the selection mode
use one of the following methods:

n Menu: Objects > Select > Selection Mode
n via shortcut keys: CTRL + 1
n toolbar: arrow tool

To select an object in the selection mode just click into the object you wish to select.

Selecting a Single Object

Make sure that you are in the selection mode and use one of the following methods:

n to select an object click into the object.
n an object can also be selected by dragging a rectangle surrounding the object

completely.
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Selecting Multiple Objects

n to select multiple objects press the SHIFT-KEY and click with the left mouse
button into the objects you wish to select.

n drag a rectangle completely surrounding the objects you wish to select. All
objects which are completely enclosed by the selection frame will be selected.

2.5.2. Moving Objects

You can reposition any selected object or change its size. While in editing mode,
these steps can be undone with the menu command Edit > Undo.

If multiple objects are selected these can be changed simultanousely, as

with a single object.

Changing Size

n select the object you require.
n drag on one of the appearing size grips to adjust the object�s size.
n while dragging the mouse pointer, a frame is created, which reflects the new

size of the object.
n release the mouse button when the object has reached the size you require.

Repositioning an Object

n select the object you require.
n click into the object to move it.
n release the mouse button when the object has reached the position you

require.

Changing Size and Position via Dialog

You can change the size and/or position of an object via the position dialog by giving
the exact size and coordinates of an object to 1/10 of a millimeter or 1/100 of an inch
respectively. This method is particularly suitable for cases in which the exact size
and/or position of an object is critical, for example when forms have to be filled out.

The position dialog can be activated in three different ways:

first of all select the object which needs to have its data changed. (Hint: only a single
object can be changed via dialog). Use one of the following methods to call the
position dialog:

n select the command Position Dialog from the menu Objects or from the
context menu

n keep the SHIFT-KEY pressed and click on the  toolbutton
n press the key combination SHIFT + ENTER

Here you can change the complete position data.
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Horizontal (x): vertical (y):

Upper Left
Corner

Distance from the left edge of
the page in mm

distance from the top edge of the page in
mm

Lower Right
Corner

distance from the left side of
the page in mm

Distance from the top edge of the page in
mm

Object Size horizontal size of the object in
mm

Vertical size of the object in mm

n in the case of label projects "page edge" means the value set by you in the
dialog Project > Page Setup without taking the offset into consideration.

n in the case of list projects "page edge" means the edge set for the printer.

Repositioning and Changing Size via the Keyboard

In addition to the mouse and position dialog, objects can also be repositioned on the
workspace via the keyboard.

n select the object you wish to reposition.
n use the CURSOR-KEYS to move the object in the direction you require. Press the

key once and the object moves 1/10 millimeter, if the SHIFT-KEY is also held, the
object is moved by 1 millimeter.

n Use the CTRL and CURSOR keys for fine adaption of the object's size
n Use the SHIFT, CTRL and CURSOR keys for a quick adaption of the object's size

2.5.3. Grouping Objects

Multiple objects belonging together can be combined into a group in order to be
treated like a single object. Please note that an object can only be a member of one
group. It is therefore not possible to combine a group into a further sub-group.

To combine two or more objects use the following procedure:

n select the objects you require
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n select the command Group from the Objects menu or from the context
menu.

n To undo a grouping select the command Ungroup from the Objects menu.

If the Properties command is called on a group of objects, the property dialogs of
the respective objects will be displayed one after the other.

2.6. Working with Layers

Selected objects can also be given appearance conditions in the layers window. These
layers are especially helpful with complex or larger projects. For larger projects it is
suggested to relate the objects on each page (first page, following pages, last page)
to their own layer. Because you can fade in or fade out these layers as required, every
page of your project can be handled separately. Otherwise the objects of different
pages would be overlapping and would make the treatment of single objects more
difficult. It can also be helpful for complex projects to relate objects with the same
contents to one layer. Even the most complex forms can be worked out without
losing control of your project.

2.6.1. Defining Layers

Layers can be defined via the command Project > Layer Definitions. The defined
layers apply to the current project.

With this command you open the dialog to edit and define appearance layers.
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Inserting Layers

In the layers window of the List & Label Designer at least one layer is defined
at any given time, which is called "Basic". When new projects are created, the

layers "Basic", "First Page" and "Following Pages" are automatically defined. With the
"New" button you can define as many further layers as you require.

To distinguish between the various layers on your workspace we recommend that you
give the various layers different colors. All objects on one layer are then
correspondingly displayed in that color. The color has of course no effect on the
actual print, and is merely a display aid.

Deleting Layers

 To remove layers which are no longer required select the corresponding layers in
the layers list and press the "Delete" button.

If the layer you wish to delete contains objects, they are automatically moved to the
basic layer. In this manner you cannot lose any objects by deleting layers.

Appearance Conditions for Layers

You can define appearance conditions for each layer. These conditions determine
under which conditions the layer should be printed. These appearance conditions
correspond to all objects of a particular layer.

Appearance conditions for single objects are given via the command Objects >
Appearance Condition.

The appearance condition for a layer can be entered directly in the field "Condition",
as long as you are familiar with the syntax. With the "Edit" button, however, it is
possible for you to open the formula wizard, in which you can combine variables,
text, and functions with any expressions. Further information can be found in Chapter
2.8 "Variables, Formulas, and Expressions".

2.6.2. Assigning Layers

The currently selected objects can be assigned to the different layers on the
workspace.

Select the objects which you wish to assign to a particular layer, and then select the
command Assign to Layer from the Objects menu or the context menu. A list with
the defined layers will appear. Choose the desired layer.

L
grafik geändert
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Double-click on the required layer to assign the
selected objects to it. Alternatively, you can
also click on the required layer and then
confirm the dialog with "OK".

The assigned objects automatically appear in
the color of the corresponding layer on the
workspace. This however only applies to the
appearance on the workspace.

2.6.3. Copying into Layers

The List & Label Designer allows you not only to assign objects to layers but also to
copy existing objects into layers.

The original object stays on its layer. A copy of the object is made on the target layer.

To copy one or more selected objects into a certain appearance layer, select the
command Copy to Layer from the Objects menu or from the context menu. This is
handy, for example when many similar objects should be used in various layers.

Switching Layers On/Off

To improve transparency in complex projects with numerous
objects you can use layers which can then be individually switched
on and off. Only the objects whose layers are switched "on" will
appear on your workspace.

You can switch layers on and off by double-clicking on the
corresponding layer in the layers window. Layers which are "on" are displayed with a
green check, ones which are "off" with a red "cross".

Depending on which option you have set on the tab "preview" (in the Options dialog
via the option "Only Visible Layers"), either only those layers which are switched on
will be displayed in the preview window, or all layers.

2.7. Object Properties

Aside from characteristics such as color, size, position and corresponding layer it is
possible to assign further properties to objects.

Determining Names for Objects

When you insert a new object on the workspace, an object description appears in the
right segment of the status line, naming the type of the object (e.g. "Text") and its
coordinates. This is the pre-set name for this object.

If you have a larger number of similar objects in your project these descriptions may
quickly become confusing. You therefore have the possibility to give objects a
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descriptive name for identification purposes via the command Name from the
Objects menu or the context menu. The name of each object is also displayed as title
of the respective context menu. If you enabled the Objects > Workspace >
Object-Info setting, the object name is also displayed in the small info window.

In the name dialog the pre-set name
(object type and coordinates) is
displayed. In the entry field underneath
you can give an individual name. The
name of the object will then appear in
the object list and in the status line.

Appearance Conditions for Objects

You can assign appearance conditions to single or numerous selected objects, which
determine under which circumstances the object should appear at print time. These
object-specific appearance conditions are defined via the command Appearance
Condition or Common Appearance Condition in the Objects menu or the
context menu. An introduction to the definition of such appearance conditions can
be found in the chapter 2.8, "Variables, Formulas, and Expressions".

Object Contents

 Alongside layout properties and appearance conditions, we also have the actual
contents of the objects, the texts, numbers, and variables which are contained in
these objects. To edit the contents of objects select the object you require and then
select the command Properties from the Objects menu or the context menu.

This opens the properties window of the required object. Variables and formatting,
etc. are examples of object properties. The type and number of properties is different
from object type to object type.

The properties of single objects are described in detail in the relevant sub-chapters of
the "Properties" chapter.

2.8. Variables, Formulas and Expressions

Information can either be inserted directly into the project as "fixed text", e.g. a
sender line on an address label or a column heading in a list. Fixed text is printed
exactly the way you have entered it into the project. Or, it can be a fixed picture, for
example your logo, or a fixed barcode.

On the other hand, the information can be taken from a database which is currently
open. Information of this kind is inserted into the projects as a "variable". In this
manner you can, for example, select the variable TELEPHONE for the contents of a list
column. The various different telephone numbers of the database records will then be
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printed in this column. Variables take the place of information from a database,
they're placeholders. Barcode contents or picture filenames may vary accordingly.

With these two types of information attractive projects can be designed which are
sufficient for many purposes. The List & Label Designer, however, offers much more.
By using formulas and expressions the information contained in variables and fixed
text can be linked and even edited. To help you with this there are "formulas" (for
calculations with numbers) and "expressions" (for the combination of text and
numeric values, and for logical conditions). In formulas and expressions you can
insert fixed text and variables in "functions" and link them via "operators".

In the case of projects for printing address labels you can, for example, add the text
"PO Box" automatically for a PO Box number saved in a variable POBOX by an
expression. In this case (formula "PO Box " + POBOX) you wouldn't just have the
bare PO Box number on the label but something like "PO Box 11 11 11".

Or, imagine you have the net prices of articles in a variable PRICE, but you actually
wanted the gross prices incl. VAT to appear in the list print. Here you can use a
formula which calculates and adds the VAT onto the net price. Of course it is the
gross price which is printed.

Logical conditions are also very useful. With these you can react flexibly within a
project to various different situations. It is usual, for example, in the case of foreign
addresses on address labels, to include the corresponding country code in front of the
postal code. On the other hand, for domestic addresses it's not necessary to include
the country code. If you now merely combine the variables COUNTRY and ZIPCODE
the country code would always be printed in front of the postal code. If you leave out
COUNTRY then the country code will never be included in the print. The solution is a
condition which checks whether the address in question is a domestic one or not. If it
is, then the COUNTRY variable is left out, if not then it is printed before the postal
code. On the basis to the principle of these IF-THEN-ELSE conditions you have the
possibility to react to the most varied situations.

2.8.1. The Elements of an Expression

Fixed text, variables, formulas, functions, links etc. - all fall under the general name
"elements of expressions" from here on. They can all be inserted and combined via the
same dialog. This dialog contains an assistant who supports you in choosing the
correct syntax, provides explanations, and help.
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Input Enhancements of the Formula Wizard

The formula wizard supports you with various input enhancements, that can be
(de)activated under Options > Formula Wizard:

n Show Function Syntax: a tooltip describing the function and parameters
appears.

n Autocomplete for Functions: after entering 2 characters all functions that fit
will be shown and can be selected.

n Autocomplete for Parameters: after entering 2 characters all parameters that
fit will be shown and can be selected.

n Syntax Coloring: functions, parameters and operators are displaed in different
colors.

n Automatic Type Conversion: variables and fields will be surrounded by
conversion functions to fit the context of the function.

Expression Modes

Please note that there are two possible modes for expressions:
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On one hand there is the normal expression mode, where variables and functions can
be used without brackets or chevrons. Fixed text must be framed by quotation marks.
Variables may be combined with the "+"-Operator.

On the other hand there is the extended mode, where fixed text may be stated as is
without quotation marks. Variables are framed by "<" and ">" and functions are
framed by chevrons "«" and "»". The chevrons  can be inserted by clicking the  button

. The combining of variables with the "+" operator is not necessary. This mode is
easier to use.

Register Tabs

The dialog consists of a row of tabs, each containing different editing elements.

Card contains the elements
Variables and
Functions

the variables and functions available for this object type

Function a list of the functions available
 + -*/ a list of the link operators available
Text a dialog for the entry of fixed text
Cond() a special dialog for the definition of IF-THEN-ELSE conditions
Date$() a list of the date formats available
Fstr$() a list of the number formats available
Tab the setting possibilities for tabs (only available in text objects)

On each of these tabs you will find an "Insert" button with which you can insert the
selected element into the editing line. Or you can double-click on the corresponding
element. You may also drag & drop the required elements from the fuction or field
list to the editing line.

There are special rules for the syntax and linking of various individual elements of an
expression (variables, text, functions, etc.). An assistant which has been integrated
into the dialog helps you creating expressions. For this reason you should always
insert the various elements into the editing line via the relevant tab of this dialog. In
order to insert variables you should use the "Variables and Functions" card, to enter
text the "Text" card, etc.

It is of course also possible for more experienced users to enter the expression directly
into the editing line or to edit the expression (e.g. place brackets), but this requires
knowledge of the corresponding syntax rules.

The Expression Field

The expression field contains an expression which you have entered either via the
various register tabs or directly.

This expression can consist of a single variable, fixed text or any combination of
variables, text, functions or operators.
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The expression is constantly checked during its "creation" for correct syntax. Any
syntax errors are displayed in the info field beneath the input field, along with a hint
as to why there is an error. As long as the expression is incomplete the check routine
displays at least one syntax error. Once the expression is complete, however, and an
error is still displayed, then the expression really does contain an error which you
should correct.

To simplify more complex expressions, you may divide them into multiple lines. This
does not affect the result.

The three buttons next to the input field are used to

n mark the brackets belonging to the formula expression

n select the whole expression framed by a pair of brackets

n undo the last step

Inserting Variables

Variables are probably the most important elements of expressions and consequently
the most important contents of objects. The variables take the place of information
which will later be filled from the application when configuring projects. The value
type ("String" (Text), "Number", "Date", "Boolean" (logical values), "Picture", �RTF� and
"Barcode") is important as soon as you want to use variables as parameters in
functions, because usually only certain value types can be used as parameters. You
can, for example, only multiply a numeric value with a numeric value and not with a
picture.

The "Variables and Functions" tab contains an overview of the variables which are
available for the current object.

Double-click on the variable you'd like to transfer to the editing line. You can
alternatively click on the variable and then insert it into the input field with the
"Insert" button or drag and drop it from the variable list. You may also drag and drop
the variable from the variable window into the input field.

The required variable is then transferred to the editing line with the correct syntax.
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To include further variables in your expression just repeat the steps described above. If
spaces should be between the individual variables, for example to separate
FIRSTNAME and SURNAME, then don't forget to enter these spaces in the editing line
too:

You may also insert variables by dragging the required variable to the

object on the workspace where it should be inserted. The variable is then

added automatically to the object as a new line.

Insert fixed text

Another very important element in expressions is fixed text, for example as prefix for
variables like

which will print like

The tab "Text" offers an easy way to insert text automatically.

Enter the text and click on the "Insert" button to insert the text into the expression
below. The assistant will try its best to insert the text in the correct syntax (with or
without operator to combine it with the rest of the formula etc.).

Inserting Linefeed

To insert a line break, click the button "Linefeed". The linefeed is
represented by a special character.

For text objects, the option "word wrap" must be enabled.
Fields/columns of table objects must have the property "fit" set to "word wrap". Please
note that if the text doesn't consist of a number of words, but of a long word it will
not be wrapped, but clipped.
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Inserting Tabs

Tabs are only available in text objects, thus the button will not
appear in fields of table columns.

Only one tab can be inserted for each line. Its position and
alignment can be adjusted using the tab "Tab". The behaviour of tabs in the List &
Label Designer isn't as you're used to from word processing environments, but is an
invisible separator between the "left" part of the text and the "right" part. For more
information please refer to Chapter 5.3 "Inserting Texts."

Inserting Functions

The built-in functions offer you flexibility in defining expressions. Functions allow you
to change the representation of fixed or variable text or numbers, recalculate and
modify values and to set a display format for these.

You'll find a list of available functions and their parameters on the tab "Variables &
Functions." A detailed description of all functions and parameters can be found in the
Appendix. The assistant tries to make life as easy as possible and displays a short
description of each function that you select. For a detailed description, refer to the
online help.

The functions are displayed in the chosen order. You may choose to sort them by

n function group (e.g. "Numerical Functions", ...)

n type of return value (e.g. "Numerical Value",...) or

n type of the first parameter (e.g. "String",...)

To insert a function, select it from the list of available functions and double click on
it, or click on the button "Insert".
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In this example, the user clicked the "Insert" button for the "dow$()" function which
returns the day of the week of the date that is passed in the parameter of the
function, ex. "Thursday".

The function is inserted in the correct syntax (with chevrons, etc.) into the function
edit field. Also inserted are place holders for the parameters which the function
expects/allows. You'll be asked to replace the place holder with a valid value. All
parameters should be replaced before continuing to define your expression.

You can also use functions for some parameters. For example:

which will print "THURSDAY". As long as you enter the functions using the "Insert"
button, the assistant will attempt to help you find the problems in the expressions.

Further examples for functions and their use will be presented in the appendix.

To insert a variable and a function simultanously, drag the required variable on the
required function folder (e.g. "Numerical Functions"). The folder will be opened
automatically and you can choose the desired function. The list is scrolled up- and
downwards if you move the mouse to the top or bottom of the list. If you drop the
variable on a function, this function will be inserted into the editing line with the
chosen variable as first parameter.

Print-Time User Input

A different type of function is the AskString$({String}, {Boolean},

{String}, {Number}). A dialog pops up, asking the user to input or modify
some data to print. The dialog is of course only shown when the data shall be printed
- optionally once per print job or for each data set.

For example, the data regarding a money transfer might be asked - the name and
account information is given by the application while the amount to be sent is
queried from the user at print time.

The following parameters define
the behaviour and appearance of
the dialog:

Parameter Meaning
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{String} This parameter contains the text to be displayed in the "group box" around the
input field, for example "Amount to transfer".
This parameter has to be supplied.

{Boolean} The second parameter lets you choose how often the dialog should be displayed
- once per session or for each record set.
.F. The dialog is only displayed once per print job
.T. The dialog appears once for each record set (unless the user presses the

"OK for All" button)
This parameter is optional, default is.F..

{String} This is the default value that should appear in the edit field f the dialog, for
example "$50.00".

{Number} Tells the designer the maximum size of input allowed. For example, give 8 to
allow up to 8 characters.

Using the "OK for All" button, the user can declare the current value to be valid for all
subsequent records in the job. Now you won't be asked again.

Insert a logical condition

Another special function is the "Cond()" function. This represents an "if - then - else"
decision: if the result of the expression in the first parameter is true, then the result of
the second parameter will be returned, unless the result of the third parameter is
used.

Assume that you have two types of currencies and you want the currency symbol to
be expressed as text instead of the symbol. This can be expressed with:

Cond(CURRENCY_SYMBOL = "$", "USD", "foreign: " + CURRENCY_SYMBOL)

Enter a condition to be evaluated,
or a boolean variable into the
condition field. Enter the "true"
part into the second line, and the
"false" part into the third. When
you press "Insert", the parts will be
wrapped into the "Cond(...)"
function and inserted into the
expression line below.

Note that the "Edit" button starts an additional assistant to help you edit the
appropriate part.

Formatting Dates

Using the dialog with the tab "Date$()" you can get assistance for date formatting.
This is just to help you, you can modify the format as you like. You can have full-text
formatting for day and month values, 2- or 4-letter representation of the year and so
on. We recommend that you insert/choose the date, and then enter the values.



List & Label - Designer General Methods and Procedures

39

To the left is the format string, to
the right the result with an date
example:

As default, the function Today() will
be selected as date parameter. Of
course you can replace it with any
date value you like:

it would display the date in a week, and so on.

More detailed information on the use of the Date$() function can be found in the
appendix.

Formatting Numbers

Using the tab "FStr$()" you
can define the format in
which a number shall be
printed in. This is how
number of digits, decimals,
leading signs etc. can be
determined. We recommend
using our assistant to insert
a format that looks as

similar as possible to the one you want to have displayed, and edit it afterwards. Take
care to format the result but not some intermediate value.

In this example, the price will be displayed with 7 digits including 2 decimals. If the
number just before the decimal point is 0, only one '0' will be displayed.

Please refer to the appendix for more formatting information.
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Operators

The tab " + */-" displays all available operators. These can be used to make
calculations, combine variables and/or fixed text, as well as to compare expression
results.

The categories are (in order of increasing priority):

n logical operators (AND, OR, NOT)
n arithmetic operators ( + , -, *, /, %)
n comparators (<, < = , = , >, > = , <>, ! = )

Please see the appendix for detailed information about the operators.

There are three columns on the dialog page. The first describes the operator, the
second is syntax and the third the type(s) of value(s) it can be applied to.

Note that " + " can also be used to add strings.

Working with Sum Variables

It is normally only possible to perform calculations within records in the List & Label
Designer. Let's assume that we have a database with articles for which we need to
create a printout. The total price for a certain amount of a particular article (ex.
article X) can be calculated from the information QUANTITY and PRICE (quantity x
price = total price). But it is not possible to calculate the total cost for a whole
selection of articles (X, Y, Z,...). For this purpose there is however a special type of
variable (which goes beyond the variables defined in the database), the sum
variables. These can be used to build sums/totals over the records, for example the
sum of the column PRICE in a table.

It is possible to optionally add all records on a particular page (page totals) or for the
whole project (totals).

Defining Sum Variables: Sums of this type can be used for all numeric values, i.e.
for numeric variables or for expressions which result in a numeric value. The following
logic applies for these sum variables :
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"@SumXX" is the sum variable in which the result of the addition is saved, "<numeric
expression>" stands for the variable or the expression which forms the basis of the
addition.

For each record which has been printed, List & Label calculates the value from
"<numeric expression>" and adds it to the "@SumXX".

To use sum variables of this kind ("@SumXX" ) in projects they must first of all be
given the required numeric expressions. This is done with the command Project >
Sum Variables.

Click the "Insert a new variable"
button to create a new sum variable
first and give a descriptive name.
When working with projects from
older List & Label versions, 50
variables "@sum01"..."@sum50" are
already predifined. To assign an
expression to the new sum variable,
click the "Edit..." button. This opens
the assistant for defining expressions.

The easiest way is to simply select a
numeric variable, ex. PRICE. The formula for the result would be:

ex. the sum of all previously printed prices is saved in the sum variable "@SumXX".

On the other hand you can also build sums via complex expressions, as long as the
result is only a numeric value. For example, you could calculate the gross price in the
expression from NETPRICE and VAT, the result would be the addition of the two. Here
is the formula for the result:

i.e. the sum of the results of the expression NETPRICE + NETPRICE * (VAT/100) is
saved in the sum variable "@SumXX".

Defining a Counter

With sum variables you can easily define the counter which is actualized for each
printed record.

In the most simple case, a counter is increased for each record.

@SumXX = 1

Page Totals and Other Totals: The option "page totals" lets you choose whether the
sum variables are reset at the beginning of each page or just once at the beginning of
the document.
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Using Sum Variables: Once you've defined the formula for the sum variables, you
can use them in the objects of your project. You can use these variables just like any
other variables.

2.8.2. Using Filters

You can use filter conditions to select the data you'd like to print. You can assign such
conditions to single objects or layers (so that they are printed or not) as well as to
data records.

First, the data is compared with the record filter. If it does not match, then the whole
record is ignored. If it matches, each object checks the layer condition and its own
appearance condition, and if one of them fails, the object won�t be printed.

For table objects, every line has an appearance condition too that is used to evaluate
whether the line should be printed or not.

Filter conditions are logical expressions, that is, expressions that return a boolean
value. Typically this is done with comparison operators ("Left$(Name,1) = 'A�). If the
result of the expression is TRUE, the record is used (or the object is printed), otherwise
the record or the object is ignored.

Record Filters

Assume that you would like to print a telephone list with local numbers, that means,
no long-distance phone numbers. Even if your database program does not allow a
selection like this, List & Label allows you to. In this case, you could use
Left$(PHONE,2)<>"1-" as expression to suppress long-distance calls.

Hint: an empty condition expression is always TRUE.

You can define such a condition using the menu commands Project > Filter.

Appearance Conditions for Layers

A condition can be assigned to a layer using Project > Layer Definitions. This
affects the visibility of all objects on this layer.



List & Label - Designer General Methods and Procedures

43

Appearance Conditions for Objects

Every object can be assigned an appearance condition too. You can define this by
choosing Object > Appearance condition or Appearance Condition in the
context menu.

2.9. Saving projects

Projects can be saved using any file name that is allowed by your operating system. It
is recommended however to use the default file extension for each project type.

2.9.1. Save

To save a project select File > Save.

When you want to save new projects using File > Save, the File > Save As
will be displayed and you can choose a name for your project.

2.9.2. Save As

To save a project under a different name or path, select File > Save As.

In addition to the filename, you can give a short description of the file which will be
shown in the file-open dialog helping you to easily distinguish your projects.

2.10. Printing Projects

List & Label offers two ways of printing: using the test print in the designer
which uses some dummy data values, and the final print with the "real" data,

initiated by the application.

2.10.1. Print Sample from the Designer

Using File > Print Sample you can have a test printout in order to check the
layout of your project.

Fixed text appears like in the final print, but variables are substituted by some dummy
data which is constant throughout the sample. Printing real data can not be done
from the designer.

Printing layers

The option "Only Visible Layers" in the options dialog, defines the way layers are

printed in the sample print. When this option is checked, only the layers visible in the

designer are to be printed, thus the sample print looks like the project in the preview

window.

Print Sample with Frames

To show the frames of the labels on plain paper, etc., you can have List & Label
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print a frame, which represents the borders of the labels.

This helps you in defining the label layout as well as the project page layout.

These frames do not appear when printing real data.

Print Sample without Frames

If you print using this menu item, the page will be printed exactly as it will
appear with real data - except that the variables have been replaced with

dummy data.

Print Sample in List Projects

When you issue one of the print commands, you will be asked whether you want the
"last page" attribute set or not. This will have an effect on the print result if you have
used the LastPage() function in the project.

Print Sample 1st Page

To print the first page of the list project, select the menu command File >
Print Sample 1st Page. This will print the first page of your project (that is,

all conditions with "Page() = 1" are TRUE and "Page()<>1" are FALSE).

Print Sample Following Page

To print a following page of the list project, select the menu command File >
Print Sample Following Page. This will print the page 2 of your project (that

is, all conditions with "Page() = 1" are FALSE and "Page()<>1" are TRUE).

The condition LastPage() will only have effect in footer lines or linked

objects.

2.10.2. Printing to Real Data Preview

In addition to the Sample Print, List & Label offers a real data preview. But in contrast
to the sample print, this can't be done in the designer, but in the application.

Refer to your application's manual for hints on how to call the preview print.
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The dialog shown on the left will be
presented which allows you to choose the
destination printer and - in case of label
projects - the starting label.

The "Change..." button allows you to select
a different printer or different printer
options than the default ones defined for
the project in the designer. This setting
does not affect the windows printer
settings.

If you'd like to permanently change these
settings, check the appropriate checkbox.
From this moment on, the new printer is

the default printer for the project to be printed.

For label projects, you can choose the position of the first label on
the first page. This is useful when printing on pages where labels have been already
used :

The dialog shows the layout of the label page.
Click on the label you want to use first during
printout taking into account the print order noted
below.

The entire print data can be viewed and printed in
a preview window. This allows you to check the
layout and data without using a single sheet of
paper. The preview can be zoomed to get a more
detailed view, as it contains all printout
information.

Printing to preview is just like printing to printer,
except that the information is not sent directly to
the printer. It is sent to an intermediate file that
the preview viewer uses to present the layout in a

window, or finally print it if you tell it to. You still have to choose the printer you
want the data to be printed to.
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The preview window is a normal window that you can move and resize as usual. The
area the printer cannot print on is displayed in a hatched grey, just like in the
designer preview.

The arrow buttons allow you to switch the page being displayed.

The scrollbar is an alternative to the buttons which allows you to switch pages
quickly.

The " + " zoom tool zooms the display by a factor of 2, the "-" zoom
tool reverts the last zooming operation. "1:1" resets the preview to
show the initial state, the whole page is shown.

Alternatively, you can use the mouse to select an area to zoom to. Click the mouse to
the left top corner of the display part you want to see, then move the mouse (keeping
the button pressed) to the lower right corner. You'll see a rectangle which is the area
that will be zoomed to when you release the mouse button.

This button sends all the pages to the printer.

This button sends the current page to the printer.

This button sends the preview information (*.LL) to your email program using
MAPI. In order to view the prieview, the receiver uses the freely available List &

Label Viewer. The receiver can also simply print the preview file - your product is not
necessary for this.

This button allows you to save the current viewer file as an *.LL file.

Ends the preview. No data is printed, the contents of this print job are lost.

L
Absatz eingefügt

L
Absatz eingefügt
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2.11. Exiting the Designer

Choose File > Exit to end the List & Label Designer session. If your layout
definition has been altered since you last saved, you'll be prompted to save the

file.

3. Menu "Edit"

The edit command is valid for objects.

Please keep in mind that the option, "Clipboard format is Text" in the options dialog
may effect the clipboard commands.

4. Menu "Project"

4.1. Page Setup...

Depending on the project type, you can choose the printer (list projects) and
the label page layout (label projects).

4.2. Filter

Information on filters can be found in the chapter "Using Filters".

4.3. Sum Variables

Sum Variables are pseudo-variables that allow you to add numerical values at print
time. They have been described in the chapter "

Working with Sum Variables".

4.4. User Variables

Formulas that are often used can be saved in so called user variables. User variables
are named @<Name> (e.g. @User01).

4.5. Layer Definition

Information regarding layers and their definition, please refer to in chapter "Working
with Layers" on page 27.

4.6. Options

This command starts the options dialog. Options are described in the chapter "Default
Values and Options".
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5. Menu "Objects"

This menu contains various operations in order to modify objects.

5.1. Select

5.1.1. Selection Mode

This command will switch the designer to the selection mode, in contrast to
one of the object modes used to insert objects.

5.1.2. Select All

This menu item will select all objects in visible layers.

5.1.3. Toggle Selection

Choose this if you want to invert the selection, that is, all selected objects become
unselected and all unselected objects become selected. This is valid only for objects
on visible layers.

This makes sense if you have to select more than half of the objects: it's easier to
select the unwanted objects and to toggle the selection afterwards.

5.1.4. Next Object

The objects are in a certain order. This command selects the object that is further
down in the object list (that is, the object printed later) than the currently selected
one.

This comes handy if two objects are so near to each other that it's hard to select the
one you like.

5.1.5. Previous Object

The contrary to the command above.

5.2. Insert

This command will offer you several object types. Once you've selected one of them,
you are automatically in the insert mode. You can insert one or several of these
objects into the project. We recommend that you insert as many objects as you need,
switch to selection mode, and edit the object's properties afterwards.
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5.3. Text Objects

Text objects are used to print text, either fixed or variable. The latter will be
replaced by the corresponding value during print.

The properties dialog is used to define the properties and contents of the object.

Edit Text Lines

Text objects are line oriented, that is, each line can (and must) be formatted
separately. You can configure options for more than one line at the same time by
selecting multiple lines.

The list control shows the lines that the text object contains. With
these three buttons you can add a line, delete the selected line(s)
or edit the selected line(s). You may add new lines via drag &

drop.

A text expression can consist of fixed text, a variable, a function or a combination of
these.

"Tab"

This is where tabulators can be set and formatted. You may set the alignment and
the position of the tabulator.

Alignment of the Tabulator

A tab is a vertical separator and
divides the text line into two
parts. The part to the left and
the part to the right are
independent and can even have
word wrapping if enabled for

that line.

  

L
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The alignment of the left part is defined by the text line's alignment, the alignment of
the right part by the tab's alignment.

n left aligned: the text is left aligned between tab and the right border of the
text object

n right aligned: the text is right aligned between tab and the right border of
the text object

n decimal: the number following the tab is aligned to the decimal point, so the
integer part of the number will be right-aligned to the left of the tab, and the
fractional part will be left-aligned to the right of the tab. There will be no
word wrap before the tab.

Tab Position: The position of the tab can be given in the system's units (inch or
millimeters). If the value is positive, it is relative to the left side of the text object, if it's
negative, it's relative to the right side. If the text object is 7 units wide, a tab position
of 5 units is the same as that of -2 units.

Tabs are usually used for expressions such as:

"Amount: $¸" + AMOUNT

Paragraph Properties

This part of the dialog enables you to set alignment, space optimization and word
wrapping. The choices always affect all selected lines.

Alignment

These icons change the paragraph's alignment - left,
centered, right aligned or block justified.

The property "Block Justify" effects text lines that are word
wrapped and printed in more than one line. All lines except the last will be block
adjusted, that is, the spacing between the words will be adjusted so that the lines are
left and right aligned.

Blank Optimization

This will optimize the blanks that unintentionally appear in a line. All sequences of
two or more blanks (spaces) are reduced to one blank character and all leading and
trailing blanks are suppressed. This makes it easier to create an expression.
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Imagine you want to write the address on a label, for example:

You would need to check any field whether it contains a value in order to get rid of
the leading blanks, for example if <Title> is empty you'd have a blank at the
beginning of the line, having it indented a small amount. Or if the Firstname is
empty, there would be two blanks in between Title and Lastname.

So the expression

is, using this "Blank Optimization" option, the same as

which looks a lot easier.

Permanent

Lines that are empty are usually ignored so that the following lines move up. This
option suppresses this automatic process, which might be needed to fill out a fixed
form.

Line Break

Allows a word wrap into several lines if the text is too long to fit in one line.

If this option is not set, the text will be cut off at the end (or the beginning,
depending on the text alignment) of the text object.

A text can only be wrapped between words, so one large word
("thisisonelinethatcannotbewrapped") will not be wrapped but clipped.

With the "Hold paragraph together" setting you can prevent a paragraph from being
wrapped by a page break.

Paragraph and Line Spacing

The paragraph spacing defines the space
between the different paragraphs of the text
object whereas the line distance gives the
distance between the lines within one paragraph.

Values are given in points - to increase the spacing to 1.5 lines using a 10 point font,
set this to 5 points. Negative values are also allowed.

Font Selection

To select the line's font style, size,
color and options, use the
"Select" button. The "Default"
button sets the font to the
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project's default font (see Project > Options).

Object Properties

Dialog Style

If this option is set the lines will be displayed as
they were formatted. If the text's size is too small
or large and thus unreadable, uncheck this
option.

Orientation

You have the option to set a text orientation in
steps of 90 degrees.

Page Wrapping

If the "Page wrapping" option is enabled, the
contents of the object will be automatically
wrapped if they exceed the object's size. This is
most interesting for text objects containing

several pages of text. For label/card projects, the next label/card is not started until all
objects with this option for the current label/card are printed.

Bottom Aligned

If this option is set, the texts will be aligned to the bottom of the text object, else
they will start at the top. If the text is larger than the text object, however, it will be
printed from the start and cut off at the botton. This option is most useful if you
want e.g. to print texts of unknown size at the bottom of a page.

Background

This options allows to select a background color for text objects. If the option
"Transparent" is disabled you can choose a color from the color selection box.
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5.4. Rectangles

A rectangle consists of a frame and interior space that can be filled or left
transparent.

Border

The "frame" options lets you the adjust the width and color of the frame.

Fill

A rectangle can be transparent (thus underlying objects shine through) or filled. If it
should be filled, select a pattern and a color.

Shade

The frame of a rectangle can have a shadow, creating a 3D-effect. Width, pattern,
and color can all be selected.

Note: A shade width larger than 0.0 has to be chosen in order for the patten
combobox to appear.

The defaults are set in the dialog of Options > Objects > Object Defaults.

5.5. Ellipse

Ellipses are similar to rectangle objects. The additional circle property forces a
circle within the boundaries of the object�s rectangle.

5.6. Lines

In the line object's properties dialog, options such as width and color can be
selected.

The defaults are set in the dialog of Options > Objects > Object Defaults.

5.7. Pictures

List & Label supports picture files with the following formats:

n .EMF Enhanced Meta Files
n .BMP Bitmaps
n .RLE Bitmaps
n .DIB Bitmaps
n .WMF Aldus Meta Files
n .TIF Tagged Image File Format (uncompressed)
n .SCR Windows Screenshot
n .PCX Bitmaps
n .PCD Kodak Photo-CD
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n .JPG JPEG-Standard
You may choose between three
different ways of using the
property dialog :

Fixed picture: if you want to
insert a picture that is independent
on the record set, choose
"Filename" and use the "Select"
button to get a filename. You may
choose to embed the selected
picture into your project file.

Variable picture: choose "Variable", then one of the picture variables, if the
application supplies them. Pictures may also be inserted with a formula. Choose the
"Formula" option, click on "Edit" and input a valid formula in the dialog. The formula
result must be that of the type: picture. You may also supply a valid filename, just
convert it to a "picture" variable using the Drawing()-function.

If the "Keep Proportions" checkbox is not marked, the drawing will be forced to fit the
object area, probably distorting it. If it is marked, the proportions (relation of width
to height) of the picture are always preserved.

5.8. Barcode Objects

Barcodes can be used for example for price labels, serial or part numbering and
more.

List & Label by default supports the following barcode formats: EAN 13, EAN 8, UPC-
A, UPC-E, 3-of-9, 2-of-5 Industrial, 2-of-5 Interleaved, 2-of-5 DataLogic, 2-of-5
Matrix, Postnet, FIM, Codebar, EAN 128, Code 128, DP-Leitcode, DP-Identcode,
German Parcel, Code 93, MSI (different sub types) and Code 11.

The properties dialog lets you choose the barcode field, type, font, color and
orientation.
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First, select whether it's a fixed barcode (Data Source: Text), from a variable (Data
Source: Variable) or from a formula (Data Source: Formula).

n Fixed barcode: choose the option "Text". Enter the text you want to be printed
as a barcode, as well as type. Note that some barcode types have restrictions
on the barcode characters and formats - if these conditions are not met, a
warning will be displayed.

n Formula barcode: Choose the Formula option and define a valid formula after
clicking the "Edit"-Button. The value returned by your formula has to be of the
type "Barcode". You may supply any variable after converting it to a barcode
using the Barcode()-function.

n Variable barcode: select "Variable" as source. Choose the variables from the
listbox (lists all possible variables).

In the field "Text" you can enable or disable the text display (again, note some
restrictions to the font display, due to layout definitions of the barcode type).

The "Appearance" group is used to set whether the barcode is printed with an optimal
size, this means that it is resized automatically according to the respective norms, or
if it is resized at will according to the object frame. This option is available for some
barcode formats only.

The "Color"- combobox is used to set the color of the barcode. Press on the button
"Orientation" to reach the dialog where the barcode can be rotated in 90 degree
steps.

If further options are available for the barcode chosen, a button "Options" will appear,
allowing you to adjust the settings.
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5.9. Tables

In order to create lists, tables, reports or similar forms, you need a table object.

A table consists of different types of table lines

n Header Lines
Typically, this is where the field names are placed

n Data Lines
They contain the data from the records of the database

n Footer Lines
They usually contain intermediate totals or final totals

n Group Lines
Can be used to group the data ("Phone numbers of " + CITY) into logical
groups. Of course they may contain data too.

n Group Footer Lines
Can be used like the group lines, but appear after conditions have changed.

If you change an option, the preview changes accordingly, in this manner you can
immediately see the effects of the properties you set.

5.9.1. Define a Layout

The last tab offers general layout options for the entire table object:
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If the Option "Fixed Size" is set, the footer line is always at the same position on the
page, independent of the amount of data in the table. If it's not, the footer "floats"
just below the last data line.

If the "Fixed Size" option is set,�Draw Separators Through� lets the table fill up the
space between the last data line and the footer with the separators of the data line
number 1.

A whole table can be assigned a default font - this option can be set in "Font
Preferences" group. "Default" will use the font of Options > Objects > Font.

Frame (border) and background colors can be chosen using the control in the "Colors"
group. If you want the table to be transparent, choose "Transparent".

The "Striped" option will color every second data line with a pattern that you can
choose. This may improve readability for large tables.

Activate the "Keep lines together" option to keep the block of data lines together if
possible even if a page break is necessary.

If you set the "Suppress data lines" option, all data lines will be suppressed
completely. This option is most useful in connection with the "Force calculations of
sum variables" option. This option tells List & Label to summarize data even if the
data line is not printed. By combining these two options, an easy print of statistics is
possible.
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If you select "Following Line on Same Page", a group line will not be separated by a
page break from the following data line. With this option enabled, a group line at the
end of a page will be automatically printed on the next page. The "pagebreak before
groupheader 1"-setting causes a page break before any group header of line
definition 1, if enabled. See the group header layout options for more details on this.

You may enter a general page break condition into the respective field. The page
break is then performed by List & Label before the line matching the condition. Edit
the condition by clicking on the "Edit" button.

5.9.2. Defining Table Lines

List & Label offers several types of table lines
allowing, for example, a separate definition
of header and data lines. These can have
different layout or column formats.

Each of the different line types can have
several formats, each being activated or
deactivated using an appearance condition .

The process is more or less alike for all the
table line types. Thus the dialog pages look
the same for them.

Hint: We recommend that you define the data line(s) first. Afterwards, when you're
finished, switch to the header line. You will be asked whether you also want the data
line definition to be transferred into the header line definition - this can save you
some unnecessary work. If you changed the data line afterwards, and then want the
automatic again, delete all header lines, change to the data line and back to the
header line:

This automation holds for all lines that you click on: if they are empty, you can select
any other (non-empty) line as the source to copy the definition from.
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Column Contents

Table lines consist of columns. Each
column is a separate entity and can
be formatted independently. It is
represented by a line in the "Columns"
list and can be either a single field or
any valid expression.

These three buttons again allow you
to 1. insert a column, 2. edit the
selected column(s) or 3. delete the
selected column(s). You may also
insert new columns by drag & drop.
Click the left part of the "New" button
to insert a normal column, click the
right part to insert an object column
(Chart or HTML).

Column Layout

The layout selected in this part is valid for all the
selected columns of the list box. When you click on
one of those properties, the valid choices are
displayed below the list.

A column is a rectangular space with a certain
width ("Width"). The printable area in this rectangle
is reduced by the distance values ("Distance Top",
"Distance Left", "Distance Right") which define
empty space between the adjacent cell (or, usually,
the separator line) and the unprintable area.

You can have several types of values in a column:
fields, barcodes, drawings, RTF formatted text and
numbers. Text can be word wrapped to become a
multiline text, or it will be clipped. Barcodes or

drawings must have a fixed height (which, when the drawing cannot be found, is set
to 0).

Width, Distance Left, Distance Right

The width is the total width of the column. To get the usable width, you have to
subtract the "Distance Left" and "Distance Right" values. If the sum of the widths of all
columns exceeds the table width, a warning will be displayed.
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You may also resize a field or column directly in the workspace by selecting the table
object and move the right separator line according to your requirements. For a more
precise adjustment we advice you to use the dialog settings.

Distance Top
This is the distance (empty space) from the line above.

Distance Bottom
This is the distance (empty space) to the next line below.

Horiz. Alignment
A text or number can be left, right, center or tab aligned. The latter is most important
for numbers so that they are aligned at the decimal point.

Vert. Alignment
As different columns might be of different heights, the columns can be vertically
aligned.

Separator
A column separator is a separating line at the left border of the column.

Separator Width
The width of the separator line can be defined. A width of 0.0 is the minimum width
(the width depends on the printer resolution), any other value is the width in system
units (1/100 inch or 1/10 mm). To switch the separator off, use the option
"Separator".

Fit
Valid fitting options are "Clipping" or "Word Wrapping". Word wrapping can only
appear in between words, thus a single long word might still be clipped.

Background
You can define a background for a column which is filled with a selectable pattern
and color, or you can have the column transparent.

Font
You can choose your own font or the default font of the line. We do not suggest that
you use a lot of different fonts as this might make the table harder to read.

Blank Optimization
This has the same functionality as the same option in the text object. It kills
unnecessary blank characters (spaces) from the expression's result prior to printing.

RTF-Text in tables
The option "RTF-Format" enables RTF formatting for the current column. If the setting
is enabled, some of the options described above are not needed anymore and are
greyed out, as the settings are made by the RTF-object.

More detailed information on using the RTF object can be found in chapter 5.10.
"Inserting Formatted Text Objects".
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Line Layout

The line layout defines the layout of the whole line.

Again, we have the font default for the columns (the hierarchical default font treating
is: column font > line font > table font > object font). We suggest that you
determine fonts in this order to minimize font switching and to ease changes. It's
much easier to change the header font (for example to boldface) than to change
several column fonts!

The "Print Margins" define the distances of
the table line relative to the table object.
"Distance Top" defines an empty space
between the line (and separator) from the
line above (and separator), "Distance
Bottom" defines the same for the bottom.
If you use this for data lines, they would
be separated by the specified amount. If
you use a "Distance Bottom" for the
header line, the data lines will be
separated from it etc. This gives you a

wide variety of choices for your table layout.

The "Distance Left" and " Distance Right" define distances from the left/right border of
the table line to the left/right border of the table object, thus indenting the table line.
If you have defined "Distance Left" for the header line to 0.0 and for the data line to
4.0, the data lines will be indented 4/100 inch

Header Line
Data Line
...

Anyway, this is more important for the relation of group lines and data lines, where
you might find it interesting and readable to have

Phone numbers in New Jersey
Data Lines

Phone numbers in New York
Phone numbers in Brooklyn

Data Lines
Phone numbers in Manhattan

Data Lines

The controls in the group "Frame" define the separator lines around the whole table
line and their widths. A width of 0.0 means that the line will be drawn as fine as
possible (dependent upon printer resolution).

Appearance Condition for Table Lines

This button will lead you to the well-known expression
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assistant.

The condition that you select here will be used in addition to the project's filter
condition (that is, if the record is rejected due to the filter condition, its appearance
condition won't be checked here!).

If you have only one data line, the project filter is generally better than the line
condition.

Multiple Layouts

Each line type can have multiple line layouts which can be switched using the
combobox with the "Line Definition..." entries. For example, you can create two data
lines that look alike except for the font (which might be boldface for one of the lines).
Then you define the condition

for the non-bold, and

for the boldface line, which will print the phone numbers for companies in boldface
while private numbers will be printed using the normal font.

Or, you might add a line which contains the name of the company the person
belongs to and which will be printed only if the person has a company's address in
the record set. If you also indent the line (line's layout dialog, see above), you can
create a list like

Private data for a person
Private data for a person
 Company Information for the person
Private data for a person
 Company Information for the person
Private data for a person

Each line type has a maximum number of 100 layouts that can be defined.

Rename Multiple Layouts

You can rename the line definitions (i.e.: "Item description 1" ). This makes it much
more easier to identify the line. To rename a line definition, select it and click in the
text an type the new text.

5.9.3. Footer Line Layout

A table often needs footer lines, to print totals of values in the data lines for example.
Footers are just like data lines with two exceptions:

n they are always the last line(s) of a table
n the "LastPage()" function can be used to distinguish intermediate footer lines

and final footer lines.
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5.9.4. Group Line Layout

Group lines are special types of table lines which can group the data lines. This makes
sense for example for alphabetical listings ("entries starting with 'A'" etc.), address lists
("People working at yyy") etc.

This requires that the application sends the data in the required order, as List & Label
evaluates and prints the data in the order it was sent. If for example the people's
names were unsorted, an alphabetical grouping would be disastrous.

Very important for the group lines are the conditions. The
"conditions" are interpreted a bit differently though. The
"condition" is not a boolean condition which defined whether

the line should be displayed or not, but a text expression, whose result will be
compared with the result of the expression of the previous data record. If they differ,
the group line will be printed. For an alphabetically sorted name list, an expression
like

as "condition" would be a good way to start. Every name that starts with a new first
character would have a new group line in front. The group line layout would contain
one column such as the folowing, for example:

As multiple layouts are possible for group lines, you can create hierarchical groups. If
you have a lot of numbers, it might be useful to create some sort of hierarchy. The
following condition would be reasonable for the second group line:

Using the indentation of table layouts, you could easily create a list like

.....
A

AA
...
data lines
...

AB
...
data lines
...

...

B
BA

...
data lines
...

BB
...
data lines
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...

The Appearance Condition

 An appearance condition can also be set for group
headers. More detailed information on that topic can be
found in the "Appearance Condition for Table Lines"

section of this chapter.

Options for group lines

Click the Options button  to get the following dialog:

Choose the sum variables, that
should be set to zero when the
group line is printed. This setting is
used to define group sums.

Choose the option "Start on New
Page" if a group header should
cause a page break (each group
begins on a new page). If more
group lines with this option set are
printed they appear together on the
new page.

5.9.5. Group Footer Line Layout

Another special type of table lines are the group footer lines. Basically they work like
the group line, but appear after conditions have changed.

5.10. Formatted Text

With the formatted text object you are allowed in contrast to normal text objects
to change the format within a line. In addition you can also use variables in

these objects.

PM
new
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When do you have to use the formatted text object and when the text object?
Normal text objects should be given preference for every day jobs, since they contain
less information and they are, therefore, printed faster. Consequently you should use
a formatted text object in case you either can not realize a special format type with
the normal text object or succeed only with great effort.

To create a formatted text object select Object > Insert > Formatted Text.:

n Create this type of object as described in chapter "Workspace".
The object is selected automatically.

n Click on the -Tool, into the object with the right mouse button, use Enter
or select Objects > Properties.

As a source you might either choose an RTF-Variable or "(Free Text)". If you select the
latter, an input box and formatting aids are displayed in the dialog, which are
explained below. Simply select the text to be formatted and choose the respective
format tool:

Select the type and size of the character.

Also select the preferred format: bold, italic, underlined, striked out, superscript,
subscript, or text color.

Select the arrangement: left, centered, right, indent a paragraph approximately at
2.5, remove the indentation, listed.

Select: insert clipboard and undo.

With this option word wrapping will be made according to object size. This is only a
reference point and will differ insignificantly.

This option allows a page wrap for the RTF object if the text exceeds one page. This
option is switched on by default. If you want to print an RTF object once on every
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page of a list project you will want to deactivate the option in order to avoid that the
object is only printed once.

With this button you can select variables or use the assistant to edit formulas.

The Context Menu

The input field has a context menu, in which you can easily choose from all available
formatting parameters for characters and paragraphs.

The RTF object also supports so-called �Embedded Objects�, i.e. objects which are
embedded into the text like graphics. You can insert them e.g. using the clipboard
from applications such as MS Paint.

5.11. Chart Objects

5.11.1. Introduction

By choosing Objects > Insert > Chart or clicking the respective icon you can
insert a chart object. This object is used for analyzing and displaying different
types of data. You can visualize the range of sales for example, the percentage

of different sources or of course "simple" bar charts. A large number of different chart
types are available and can be used for diverse applications. Most chart types have
different sub types.

In general, three and two axis charts are differed. Three axis charts have three data
axes and can be used to visualize the sales range per month and employee, for
example. A two axis chart has only two data axes and shows e.g. the sales range of
the whole company over a number of months.

5.11.2. Selecting the chart type

Double click a chart object to reach to the property dialog.
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Choose the chart type from the list on the left hand side. The following types are
available:

Pie Chart: a typical pie chart.
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Cylinder/Bar/Pyramid: bar chart flavors differing
in the shape of the bars.

Ribbon:  a three dimensional ribbon chart.

Line/Symbols/Line & Symbols: two dimensional
charts.

5.11.3. Selecting the sub type

Depending on the chart type chosen, up to eight different sub types become
available.
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Sub types for cylinder, bar and pyramid charts:

Multi row: A "normal" 3D chart, showing the
sales per month and per employee, for example

Simple 3D/Simple: Only two axes are available,
showing the total amount of sales per month for
example. The simple type is without the 3D
effect.

Clustered 3D/Clustered: Values on the x axis are
grouped allowing a direct comparison of values.
The clustered type is without the 3D effect.

Stacked 3D/Stacked: This chart type is designed
to show the share of each contribution, e.g. the
share of sales each employee contributes to the
total. This type is not available for pyramid
charts. The stacked type is without the 3D effect.
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100% Stacked 3D/100% Stacked: Similar to the
stacked chart, single contributions can be
visualized with this chart. This chart type,
however, shows percentual values. The value of a
month's sales always equals 100% and the
percentage of contribution for each employee
can be extracted from the diagram. This type is
not available for pyramid charts. The stacked
type is without the 3D effect.

Sub types for line and symbol charts:

Simple/Multiple: The values are visualized as dots
in a coordinate system. Depending on the type,
the dots are connected by lines. A multiple
diagram contains more than one line.

Stacked: This chart type is designed to show the
share of each contribution, e.g. the share of
sales each employee contributes to the total.
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100% Stacked: Similar to the stacked chart,
single contributions can be visualized with this
chart. This chart type, however, shows
percentual values. The value of a month's sales
always is 100% and the percentage of
contribution for each employee can be extracted
from the diagram.

5.11.4. Chart properties

The chart object provides a variety of options. Depending on the chart type, there are
two or three data axes. Using the tabs you can switch from one axis to another. You
have the following options:

Pie charts

Pie charts have a special position; there are no actual "axes" but segments. Thus, the
configuration differs from that of the other chart types.

Options for the datasource

Datasource Choose the datasource for the segments, e.g. "Name" for people, "Month" for
date values, and so on.

Filter condition If you like you can define a filter condition. Only the records matching the
condition will be used for the chart data (e.g. Left$(Name,1) = �A�).

Legend Choose the position of the legend. If you choose  "at chart" the values are given
directly at the segments.

Segment labels Choose the text which should be used to label the legend. Some preconfigured
values are available, e.g. "Value and Percentage without decimals". Alternatively
you may enter your own formula, choose "Formula..." from the list in order to do

so. By clicking on  you may also enter a formula. The  allows you to set
the font for the labels. A left click  opens a file selection dialog, a right click
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resets the font to the default object font.

Color data row The segments are colored with different colors in order to make the diagram
easier to read.

Number of
sample rows for
the Designer

The designer has no access to the "real" data which will appear in your chart
when printing. In order to have a picture of how your chart is going to look like,
you can set the number of segments to appear in the Designer here.

Options for the type of calculation

Calculation mode
for equal values

Specifies the handling of equal source values. An example: you want to have the
sum of sales to your customers. In this case, choose  "sum of values". If you're
interested in the average price of sales to a customer, choose "mean value". If
only the number of sales to a customer is of interest, choose "number of values".
As the actual value is not of interest in this case, the source field will be
deactivated.

Source for
segment size

Choose the datasource for the segment size, e.g. "Value", "Price" etc.

Minimum share Especially when having lots of small contributions it may be desirable to
summarize these in a common segment. Choose the maximum value up to
which the segments will be summarized.

Summarize lower
values as

Defines the label for the summarized segment. If you do not enter your own
formula, the label will be adapted to the "normal" segment label layout on the
datasource tab.

Other chart types

Options for category and series axis

If you chose to have a three axis chart, both axes are available (as x and y-axis). Only
the category axis is needed (as x axis) for two axis charts. You have the same options
for both axes:
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Datasource Choose the datasource for the row, e.g. "Name" for people, "Month" for date
values, and so on.

Filter condition If you like you can define a filter condition. Only the records matching the
condition will be used for the chart data (e.g. Left$(Name,1) = �A�).

Legend Choose the position of the legend. If you choose  "at chart" the values are given
directly at the axis. Else, a legend will be added on the left, right, bottom or top
of the chart.

Data labels Choose the text which should be used to label the legend. Some preconfigured
values are available, e.g. "Value of source". This setting will display the source
value on the axis, i.e. the name of a customer, the month,...
 Alternatively you may enter your own formula. Choose "Formula..." from the list

in order to do so. By clicking on  you may also enter a formula. The 
allows you to set the font for the labels. A left click  opens a file selection dialog,
a right click resets the font to the default object font.

Axis label
Choose a text for your axis label here. By clicking on  you may also enter a

formula. The  allows you to set the font for the labels. A left click  opens a
file selection dialog, a right click resets the font to the default object font.

Color data row This attribute may only be chosen for either the series or the category axis. The
chosen data row will then be colored in altering colors.

Number of
sample rows for
the designer

The designer has no access to the "real" data which will appear in your chart
when printing. In order to have a picture of how your chart is going to look like,
you can set the number of values to appear in the designer here.
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Options for the value axis

Calculation mode
for equal
coordinates

Specifies the handling of equal source coordinates. An example: you want to
have the sum of sales to Customer smith in January. In this case, choose  "sum
of values". If you're interested in the average price of your sales to this customer,
choose "mean value". If only the number of sales to the customer is of interest,
choose "number of values". As the actual value is not of interest in this case, the
source field will be deactivated.

Datasource Choose the datasource for the value axis, e.g. "Value", "Price" etc.
Range You can limit the shown data range in order to e.g. regard huge divergences

within the values. If your values have high peaks, you can cut them off by
setting a max limit. If you leave the default setting "automatic" the chart will
display all values.

Legend,
Coordinate labels,
Axis label

These options are the same as for the series and category axis. The legend can
only be displayed at the chart or not at all, however.

Options for the chart object

On the options tab you may set different layout options for the chart object.
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Title Choose a title for your diagram. This title will be displayed above your chart. By

clicking on  you may also enter a formula. The  allows you to set the
font for the labels. A left click  opens a file selection dialog, a right click resets
the font to the default object font.

Width Sets � depending on the chart type � the bar width, the line width or the width
of the segments.

Perspective Choose the level of perspective for your object here.
Angle of
inclination, Angle
of rotation

Sets the rotation of the diagram. You may also set these angles using the
rotation buttons which appear when the chart is selected on the workspace.

Color options

On the colors tab you can set the colors for your chart.

Background Choose the color for the "back wall" of the chart. Alternatively the wall may also
be transparent. To choose a color, select it from the upper combo box. The "..."
entry brings up a standard color selection dialog.

Color map Choose the colors and the order of colors for the chart. For a bar chart, this is
the color of the bars, for a pie chart the segment color. To choose a color, select
it from the upper combo box. The "..." entry brings up a standard color selection
dialog.

5.11.5. Examples

Chart options depend on the available data of course. Thus, the following examples
need to be kept general. A fictive application may give you the fields "Name", "Month"
and "Sales", denoting the name of your customer, the month in which a transaction
took place and the total transaction volume.

Multi row bar chart

This would be the simplest way to analyze your data; you'd have a diagram showing
the total transaction volume for each month and customer
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...this is how it's done:

Insert a new chart object, choose "Bar" as type and "Multi row" as sub type. Choose
"Month" as the datasource for the category axis and "Customer" as the datasource for
the series axis. For the value axis, choose "Sales". Edit the axis labels and title as
required � you're finished.

Pie chart

If you're interested in the share each customer contributes to the total sales over a
number of months, you'd choose a pie chart. This chart directly displays the shares:

...this is how it's done:

Insert a new chart object, choose "Pie" as type and sub type. Choose "Customer" as the
datasource and "Sales" as the datasource for the segment size. Edit the axis labels and
title as required � you're finished.
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100% stacked bar chart

The pie chart in the last example shows the share over a number of months.
However, to quickly take a look at the shares for each month and extract trendlines, it
would be interesting to see the change in the shares over a number of months. The
100% stacked bar chart is perfect for this.

...this is how it's done:

Insert a new chart object, choose "Bar" as type and "100% stacked" as sub type.
Choose "Month" as the datasource for the category axis and "Customer" as the
datasource for the series axis. For the value axis, choose "Sales". Edit the axis labels
and title as required � the procedure is exactly the same as for the multi-row bar
chart. This is why you can simply switch between the two sub types without having
to reconfigure your datasources.

5.12. HTML formatted text

To display HTML formatted text (e.g. web sites) within your projects, you can
use the HTML text object. Please note that due to license restrictions no GIF
files can be displayed.

The object supports the HTML 3.2 specification. Partially supported are some
extended tags as well as cascading style sheets.

To insert a HTML text object use the tool bar or Objects > Insert > HTML-Text.

The contents of the object are edited in the properties dialog, where you have various
options.
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n File � choose this option to display the contents of a previously saved HTML
file. The "Browse..." button opens a file selection dialog. The file must be
located on a local storage medium or network.

n URL � this option is used to display websites (e.g. www.combit.net). The
contents are downloaded at runtime, thus you'll need a connection to the
Internet in this case.

If your access is via proxy server, which is the common case in companies,

you must enter its address in the settings group. By default, your current

proxy configuration will be set. Leave this setting in order to be able to

distribute your projects to other systems with a different proxy

configuration. The current configuration will always be taken in this mode.

n Field/Variable � if your application makes HTML contents available, these can
be chosen here. Refer to your application's documentation for details.

Fit to Object: Choose this option to fit the contents into the object. If the option is
deactivated, the contents are fit to the object width and output may wrap over
several pages.

5.13. Arrange

The workspace can have a lot of objects that can even overlap or cover each other.
You can, for example, put a picture behind a transparent table to make your
presentation more interesting etc. Look at this as if each object is on a transparent
sheet, and the order of these comes into play whenever you have a non-transparent
object. You can look at the order using the object list (Objects > Object List).

You see that the order of the sheets is important, as you don't want the picture to
cover the table, then your information would be invisible.
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Using Objects > Arrange, you can rearrange the sheets of the selected objects so
that they have the order you need.

Please note that these "sheets" (just a term in this case) have nothing to do with the
layers.

5.13.1. To Front

All selected objects are moved on top of the stack of sheets, that is, they have
priority to the objects lying deeper. In our example, you must have the table in

front of the bitmap.

5.13.2. To Back

This is the contrary to To Front: it puts the selected objects to the bottom of
the stack of sheets. In our case, you could use this to put the bitmap to the

bottom. As this is some sort of "background", this would be a little more logical than
putting the table in front, but if no other objects overlap these two, there's no
noticeable difference.

5.13.3. Forward One

The selected objects will be moved one position up in the stack of sheets.

5.13.4. Back One

The selected objects will be moved one position down in the stack of sheets.

5.13.5. Alignment

If you have multiple objects selected, you can align them in the selection rectangle
using the following methods.

Each direction (horizontal and vertical)
has 6 alignment methods. Choose the
ones you like, even horizontal and
vertical simultaneousely. If the objects
should not change in one direction,
leave the method of this direction to
"Unchanged".

Left / Right / Top / Bottom:

The methods reposition the selected
objects at the corresponding border of

the selection rectangle. They will not change in size.

Centered:

The objects will be placed at the center of the selection rectangle. They will not
change in size.
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Size Fit

The objects will be resized to fill the selection rectangle in the corresponding direction
(horizontal or vertical). Thus they will all get the same width or height.

Equal Shape Distance

The selected objects will be repositioned so that the distances between their frames
are constant. If the objects are equal in size, this is the same as Equal Center
Distance.

Equal Center Distance

The selected objects will be repositioned so that the distances between their centers
are constant.

Unchanged

Choose this if you do not wish to make any changes in the corresponding direction.

5.14. Group

You can combine objects to a group. This will cause them to be selected as one
object. This again means all operations (resizing, moving,...) will take place on all
member objects of this group. An object can only be member of one group, thus
groups cannot be put into groups.

To group objects, mark them and use the Objects > Group command (also
accessible from the context menu).

To undo a grouping, select the group and choose Objects > Ungroup.

5.15. Assign to Layer

You assign objects to one of the available layers. See chapter 2.6.

5.16. Copy to Layer

Objects can be copied using this command so that they exist in the current and the
selected layer.

5.17. Properties

 This brings up the properties dialog of the selected object.
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5.18. Edit Position Dialog

This will bring up the positioning dialog where you can define an object's position
and/or size in the highest possible resolution.

5.19. Appearance Condition

The expression assistant will help you through the creation process of the expression
for the appearance condition.

5.20. Common Appearance Condition

This will set the appearance condition for all selected objects. All selected objects will
get the condition you define in the expression assistant.

5.21. Name

You can name objects. This name should be unique within your project. The name
then is displayed in the status bar as well as in the object list. This gives a visual aid to
distinguish objects and their purpose.

5.22. Object List

The object list displays the list of objects belonging to the current project. If you have
defined meaningful names for the objects, this list can help you to identify and
rename objects, and change their properties.

Objects in invisible layers are greyed and cannot be selected.
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When you select an object in the object list, the corresponding visual representation
will be selected in the workspace. This enables you to check your selection, or to
select objects that are virtually unselectable when several objects of the same size are
on top of one another.

Editing or Deleting Objects

This can be done using the "Edit" and "Delete"- Buttons. You may also
start the object properties dialog by double-clicking on an object in the
list. If multiple objects are selected when clicking the "Delete" button, all

objects are deleted.

Lock objects

The checkbox "Editable" allows an object to be selected on the workspace, or not. If it
is not selectable on the workspace, the only way to select it is using this object list
dialog.

Naming Objects

The edit control allows you to change the name of the selected object. The name is of
course the same name that can be changed using Objects > Name.

Resetting the Name

The "<-Default" button will set the default text (type and coordinates) as the name of
the object.
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5.23. Linking Objects

By linking objects you can make sure that one object is printed after another (either in
time or space). A linked object may also adapt its size to the parent object (ex. table).
Keep in mind that tables can not be linked to each other. The linked objects are
placed in a "parent-child" hierarchy. The object, that other objects are linked to,
becomes a parent object. The objects linked to a parent object are child objects.

Click this button to link objects to the selected object in the
object list. A list of available objects in your project is displayed. Choose the object
that you want to link to the parent object. The links are shown in the object list in
Windows Explorer style. You can easily tell which object is the child and which object
is the parent object. To link more than one object to the parent object, repeat the
steps described above.

5.23.1. Link Types

Once you select a linked object, the type of link can be set in the concatenation type
tab. The options are:

Sequential

A sequential link means the child object will be printed after the parent object. This is
useful, for example, if you want to state the number of records on the current page in
a table. This number, of course, is only known after printing the table. By linking the
counter field sequential to the table, you ensure the correct result to be printed.

The sequential link is the default setting after linking two objects. It is symbolized by
an hourglass icon in the object list.

If a sequential link is chosen, none of the options for adjusting position or size in the
concatenation type group are set.

Link in Space

A link can also affect the position and size of the linked object. A size and position
adaption implies automatically a sequential link. If the parent object is smaller
than the maximum space available, the linked object can use this to move relative to
that change to have a constant distance to the lower edge of the parent object.
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For example, if you link an object to a table object using "Position adaption: Vertical,
to end". The object will have a constant distance to the footer line of the table and
will "float" along with it when the size of the table changes.

These settings will only affect printing as they depend on the change of the

object's size due to the data that is being printed. Changes in the workspace

on the parent objects do not have an effect on the child objects.

The symbol for this type of link is a rectangular shape with one or more arrows.

The choosen link type is displayed on the Concatenation Type tab.

Individual Size and Position Adaption

The link type will be choosen over the tabs Vertical Concatenation and Horizontal
Concatenation. In each case 2 different kind of link mechanisms are available:

Link Type: Position Adaption: means that the position of the child object will
adapt to the changes of the parent object's position.

n Option "Relative to Begin": the child objects moves like the top left corner of
the parent object.

n Option "Relative to End": the child objects moves like the bottom right corner
of the parent object.

n Option "To End": the top line of the child objects begins at the end of the
parent object independant of the original position. This causes an implicit
adaption in size on the first page the child object is printed on.

Link Type: Size Adaption: means that the size of the child object will adapt to the
changes of the parent object's size.

n Option "Proportional": the size of the child objects changes like the size of the
parent object. If the parent object will be 1 inch smaller the child object will
be 1 inch smaller.

n Option "Inverse": the size of the child object changes in the opposite direction:
if the parent object shrinks by one inch, the child object increases in size by
one inch.

Horizontal Concatenation

The child object adapts the position resp. width to the corresponding changes of the
parent object. Which corner is the decisive one depends on the choosen option.

Vertical Concatenation

The child object adapts the position resp. height to the corresponding changes of the
parent object. Which corner is the decisive one depends on the choosen option.

If both options "Horizontal" and "Vertical" are set, the child object adapts to both
changes of the parent object.
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Keep Size

If you want to link an obect to another object so that the child objects keeps its size
but adapts its position so that it starts under the parent object choose the link type
"At End, Keep Size". In contrast to the plain position adaption this options cares about
the available space. If neccessary a page break is done and the child object starts on a
new page. You can use this option to place multiple objects (pictures, charts, etc.)
underneath each other. In this case the "base object" us the first object in the
hierarchy with activated page break.

Detach link

Using this button you can unlink the selected object. It then is
available again as single object in the object list.

5.23.2. Examples

As stated above, links in time should be used whenever the contents or conditions set
in the child object are not available or met before the parent object is printed. It is,
for example, inevitable to use a link in time to use the function LastPage(). If you
want to print the total price on the last page of an invoice, you may insert a text
object with the appearance condition LastPage() and link it in time with the table
containing your items. If the link was omitted, the object would never be printed, as
variables (text objects) are printed before fields (tables) by default, and the total price
is not available at that time, nor whether the current page is actually the last page.

A common use for links in space is the printing of invoices. An invoice usually consists
of a table, which holds the items of the invoice. The first page, of course, should be
different from the others, because it contains the invoice header with your address,
logo etc. On the first glance, one would insert two table objects in different layers,
one for the first page, the other one for the following pages. By using an inverse,
vertical size adaption, you get by much easier: Design an invisible frame on the base
layer (see chapter 5.4. "Inserting Rectangles"), which begins where the invoice table
should start, and ends where the invoice table should start on page one. Choose
"Page()=1" as appearance condition for the rectangle and link the table (child) to the
rectangle (parent). Choose an inverse, vertical size adaption and a position adaption
vertical, relative to end. In this way you solve your problem with just one table and
don't have to update both tables if you change your table design later on.

A typical example for a "keep size" link is a chart object that should be printed at the
end of a table object. In most cases you know what size the chart should have. Place
the chart object in the desired size an link it to the table object. Check the options
"At End, Keep Size". Independant of the final ending of the table object the chart
object is printed under the table object in the desired size, if neccessary on a new
page.
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6. View

The View Menu offers different options for the appearance of the designer.

Zoom

For precise work in the designer different zoom modes are available:

n Full View ALT + 1
n 2 times ALT + 2
n 4 times ALT + 3
n 8 times ALT + 4

The current zoom mode can be seen in the menu.

View Mode

With the options "Layout", "Layout Preview" and "Preview" you can choose the view
mode.

Windows

With this menu you can determine weather different windows are visible or not.

7. Options

This command uses the same dialog as described under Project > Options except
that it starts with the dialog page Preview, and isn't project specific.
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8. Appendix

8.1. Expressions

8.1.1. Syntax

The expressions all use the same syntax, and look quite like that of the programming
language BASIC:

Result = Expression(Parameters)

You enter the expression and List & Label calculates the result. Lower/upper case are
not important for functions, but imperative for arguments:

There are basically two types of formulas:

n Conditions (which return a boolean result: TRUE or FALSE)
n Expressions which may result in different types of return values (barcode,

picture, string, number, date or boolean). Which type of result is expected is
obvious, from where the expression is used and the syntax. This which will
inform you of the result type that is necessary.

Element Meaning
Expression() An expression combining functions, text and variables.
Parameters Values used in the expression to calculate the result. Usually they are the

variables from the database but can also be constant numbers, texts or
such.

Result The value List & Label calculates from the expression and the parameters.

8.1.2. Value Types

Type Meaning
BOOLEAN Logical values TRUE or FALSE. If the condition is met, the value is TRUE, else

FALSE.).
STRING Any combination of letters and numbers. If this is used as fixed text, it must

be in single or double quotation marks.
DATE A number representing the date using a Julian calendar.
NUMBER A numerical value.
BARCODE A string used as barcode text.
PICTURE A supported graphic format.
RTF A formmatted text

8.1.3. Function Overview

The available functions are listed in the "Function" dialog page of the formula wizard
along with their parameters and usage.
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Arguments in brackets are optional. A function must be followed by parentheses,
even when it doesn't have parameters, Today(), for example.

The argument type "ALL" means that the argument can be of any type, SAME means
that this argument must be of the same type as the ALL parameter.

8.1.4. Examples of the function usage

The function "Empty(STRING)"

The function "Empty(STRING)" checks, whether the argument string is empty or
not. If it is, it returns TRUE.

This is intended for use in the IF-THEN-ELSE condition:

It has the same effect as Length(STRING) = 0.

The function "FStr$(NUMBER, STRING)"

"FStr$(NUMBER, STRING)" formats a numeric argument (NUMBER) using the
format string (STRING). It returns a string with the formatted number.

The format string can contain the following characters:

Format Meaning

* number or '*'-Prefix

$ number or '$'-Prefix

- number or sign (when numerical argument negative)

 + number or sign

( number or '('-Prefix (when numerical argument negative)

) ')'-Postfix (when numerical argument negative)

# number or space

& number or '0'

. decimal point

, 1000-comma or space

The 'or' part will be taken when the number is too small to fill the position of that
format character.

A prefix is a character which is written in front of the number. The formula
FStr$(1, "***") has "**1" as result. In case of FStr$(100, "***"), the
result would be "100". A postfix is put behind the number.

As an example, assume you want to format the number of software products you're
selling and that number would be in the variable QUANTITY.

Fstr$(QUANTITY, "#####&")

formats the number to 6 significant digits. Every place except the smallest can be
blank if the number is too small.
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Value result

0 "  0"

1 "  1"

255 " 255"

Imagine that you have the price of that software in PRICE and you need it with two
decimals (rounded):

Fstr$(PRICE, "#####&.##")

Value result

999.55 " 999.55"

1100 " 1100.00"

1099.5 " 1099.50"

You want the total price? No problem:

Fstr$(QUANTITY*PRICE, "$$, $$$, $$&.##")

We use the '$' here to show this feature:

Value result

2*999.55 " $1, 999.10"

1100 " $1, 100.00"

100*1099.5 " $109, 950.00"

Some additional examples:

Formula Result

FStr$(3.142, "#.###") "3.142"

FStr$(3.142, ".######") "*******" (overflow!)

FStr$(3.142, "(&.###)") " 3.142 "

FStr$(3.142, "(&.###)") "(3.142)"

FStr$(3.142, " + + +
&.###")

" + 3.142"

FStr$(3.142, "---&.###") " 3.142"

FStr$(-3.142, "---
&.###")

" -3.142"

FStr$(3.142, "&&&.&&&") "003.142"

FStr$(3.142, "***.***") "**3.142"

FStr$(3.142, "$$$.$$$") " $3.142"

FStr$(5003.1,
"#,###.&&")

"5,003.10"

FStr$(3.142, "##&.***") " 3.142"

The function "If(<BOOLEAN>, <ALL>[, <SAME>])"

This function (as well as the "Cond({Boolean}, {All}, {Same})" function
which is equivalent) gives you the opportunity to use conditional expressions. It can
be interpreted as a function that represents the IF-THEN-ELSE statement in
programming languages. Please keep in mind that both expressions are evaluated, it's
not possible to assume boolean shortcut evaluation.
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Depending on the boolean first argument, the value of the second (if TRUE) or the
third argument (if FALSE) is returned.

If the third argument is empty, the return value defaults to

type of 2nd argument result if 1st argument is FALSE
Boolean FALSE
String "" (empty string)
Date Julian date 0
Number 0
Picture "" (empty string)
Barcode "" (empty string)

Imagine your database has a COUNTRY field which contains the country code (maybe
not, if it's in your own country). This field shall be inserted before the city name in
CITY (if it is not your country, assumed USA here). Then you'd use the following
formula:

Once you've written a few formulas, they will become easier to use and you will be
pleased with the flexiblity that you gain.

The function "LastPage()"

"LastPage()" returns TRUE if the current page is the last or FALSE if not. LastPage()
has no arguments, still the parentheses have to be written to declare it as function
usage.

As example we assume you want to have a 'sum' line at the bottom of a page which
displays the current subtotal or total:

The function "Left$(STRING, NUMBER)"

The function "Left$(STRING, NUMBER)" returns the first NUMBER characters of
the STRING.

Formula result

Left$("combit", 2) "co"
Left$("combit", 10) "combit"

8.2. Order of priority

In an expression, a lot of operations can be performed. Operators, functions,
parentheses - all in one formula. Thus it can be important to use parentheses to
change the order of evaluation.
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The order of priorities is

Priority Operators
1 Parentheses ()
2 Functions
3 Logical operator NOT
4 Logical operators AND, OR, XOR
5 Arithmetical operator modulo (%)
6 Arithmetical operators (*, /)
7 Arithmetical operators ( + , -)
8 Relational operators (<, < = , = , > = , >, <>, ! = )

8.2.1. Operators

Operators combine two values to make a result, except for the negation operator
NOT, which just takes one value. Operators are used to calculate (mathematical
operators), compare (relational operators) or combine (logical operators).

Operator Meaning Data Types Result Types
> Greater than STRING, NUMBER, DATE,

RTF
BOOLEAN

> = Greater than or
equal

STRING, NUMBER, DATE,
RTF

BOOLEAN

< Less than STRING, NUMBER, DATE,
RTF

BOOLEAN

< = Less than or equal STRING, NUMBER, DATE,
RTF

BOOLEAN

 = Equal STRING, NUMBER, DATE,
RTF

BOOLEAN

 = = Equal STRING, NUMBER, DATE,
RTF

BOOLEAN

<> Not equal STRING, NUMBER, DATE,
RTF

BOOLEAN

! = Not equal STRING, NUMBER, DATE,
RTF

BOOLEAN

% Modulo NUMBER NUMBER
 + Add STRING, NUMBER, DATE STRING, NUMBER, DATE
- Subtract NUMBER, DATE NUMBER, DATE
* Multiply NUMBER NUMBER
/ Divide NUMBER NUMBER
AND Logical AND BOOLEAN BOOLEAN
OR Logical OR BOOLEAN BOOLEAN
XOR Logical exclusive-

OR
BOOLEAN BOOLEAN



List & Label - Designer Index

92

9. Index

Alignment  78
Appearance Condition  80
Appendix  86

Expressions  86

Arrange  77
Alignment  78
Back One  78
Forward One  78
To Back  78
To Front  78

Back One  78
Barcode Objects  53

Insert  53
Properties  53

Barcodes  13, 53
Bitmaps  52
Blank Optimization  49
Border  52
Buttons

Copy  11
Cut  11
Delete  11
Edit  11
Move  12
New  11
Online-Help  11
Paste  11

Chart Objects  65
Charts

100% Stacked  68
Axis Label  72
Category Axis  71
Clustered  67
Colors  74
Data Labels  72
Datasource  70
Examples  74
Filter  70
Legend  70
Line  66
Minimum Share  71

Multi Row  67
Options  73
Properties  69
Range  73
Ribbon  66
Sample Rows for Designer  70
Segment Size  71
Series Axis  71
Stacked  68
Sub Types  67
Type of Calculation  71
Types  65
Value Axis  73

Circles  13
Common Appearance Condition  80
Condition for Table Lines  60
Context menu  8

Dates
Formats  38

Dialog Style  51
Dialogs  11
DIB Bitmaps  52
Drag & Drop  11

Edit  46
Edit Position Dialog  79
Editing Objects  23
Ellipse  13, 52

Insert  52
Properties  52

Embedded Objects  65
Exit  45
Expression  31, 86

Date Formats  38
Examples  87
Fixed Text  34
Functions  35
Numeric Formats  39
Operators  39
Print-Time User Input  37
Syntax  86
Value Types  86

Expression Modes  32



List & Label - Designer Index

93

File
Exit  45
New  14
Open  14
Print Sample  43
Save  42
Save As  42

Fill  52
Filter  41, 46

Records  41

Fixed Text  34
Font  50
Footer Lines  61
Formatting Numbers  39
Formulas  31
Forward One  78
Functions  35, 86

Cond()  88
Empty()  87
FStr$()  87
If()  88
Lastpage()  89
Left$()  89
Print-Time User Input  37

General Methods and Procedures  13
Group Lines  61, 63
Grouping Objects  26

Help  11
HTML-Objects  76

Insert
Barcode Objects  53
Chart Objects  65
Ellipse  52
HTML-Objects  76
Insert an Object  47
Lines  52
Lists  55
Pictures  52
Rectangles  51
Tables  55

Text Objects  47

Interface  6

Keyboard  26

Labels
Define Format  17
Paper Format  15
Predefined Formats  17
Print Order  18

LastPage()  89
Layer Window  10
Layers  27

Appearance Condition  28
Assigning  28
Assigning Objects to  79
Copying Objects into  29
Copying Objects to  79
Define  27
Definition  46
Delete  28
Insert  27
Toggle Visibility  29

Line Chart  66
Line Properties  49
Line Spacing  50
Linefeed  35
Lines  13, 52

Insert  52
Properties  52

Linking Objects  81
Examples  84
Link Types  82

Lists  13, 55
Insert  55
Paper Format  18
Properties  55

Menu Bar  6
Moving Objects  25

Name  80
New  14



List & Label - Designer Index

94

Next Object  47

Object Bar  7
Object List  80
Object Properties  29
Objects  47

Appearance Condition  80
Appearance Condition  30
Arrange  77
Assign to Layer  79
Assign to Layer  28
Common Appearance Condition  80
Contents  30
Copy to Layer  79
Copy to Layer  29
Edit  23
Edit Position Dialog  79
Ellipse  52
Grouping  26, 79
HTML-Objects  76
Insert  47
Insert  23
Lines  13, 52
Links  81
Moving  25
Name  80, 81
Names  29
Object List  80
Pictures  52
Properties  79
Rectangles  51
Select  47
Sizing  25
Text Objects  47

Online-Help  11
Open  14
Operators  39, 90

Order of Priority  89

Options  46, 85
Alignment Grid  19
Compatibility  21, 23
for Objects  19
for Projects  18
for Workspace  21
Precision  19

Orientation  51

Page Layout

Labels  15
Lists  18

Page Setup  46
PCX Files  52
Picture File  13, 52
Pictures  52

Embed  53
Insert  52
Properties  52

Position and Size Dialog  25
Preview  9
Previous Object  47
Print  43

Printer  44

Print Sample
Lists  43

Print Sample  43
Project  6, 46

Filter  46
Import  15
Layer Definitions  46
Open  14
Options  46
Page Setup  46
Print  43
Save  42
Save As  42
Sum Variable  46
Types  15
User Variable  46

Project  8
Properties of Objects  79

Record Filters  41
Rectangles  13, 51

Border  52
Fill  52
Insert  51
Properties  51
Shade  52

Resizing Objects  25
Ribbon Chart  66
RLE Bitmaps  52
RTF Text  63
Rulers  6



List & Label - Designer Index

95

Save  42
Save As  42
Select  47
Select All  47
Selection

Invert  47
Next Object  47
of a Single Object  24
of Multiple Objects  24
of Objects  24
Previous Object  47
Toggle  47

Selection Mode  47
Shade  52
Sizing Objects  25
Sketch in File Dialog  15
Statistics  56
Status Bar  9
Sum Variable  46

Table Objects  55
Tables  13, 55

Column Layout  58
Condition for Lines  60
Defining Table Lines  57
Footer Line Layout  61
Group Line Layout  61, 63
Insert  55
Layout  55
Multiple Layouts  61, 63
Properties  55
RTF-Fields  59

Tabs  35
Tabulator  48
Text and Variables  13
Text Objects  47

Dialog Style  51
Edit Text Lines  48
Font  50
Insert  47
Line Spacing  50
Linefeed  35
Orientation  51
Permanent Lines  50
Properties  47
Tabs  35

Variables  33
Word Wrapping  50

TIFF Files  52
To Back  78
To Front  78
Toggle Selection  47
Tool Bar  7

User Variable  46

Variable List  10
Variables  33

WMF Files  52
Workspace  8

Zoom  84


	Introduction
	The Designer Interface
	Dialogs

	General Methods and Procedures
	Projects
	Determining Page Setup
	Default Values and Options
	Inserting Objects
	Editing Objects
	Working with Layers
	Object Properties
	Variables, Formulas and Expressions
	Saving projects
	Printing Projects
	Exiting the Designer

	Menu "Edit"
	Menu "Project"
	Page Setup...
	Filter
	Sum Variables
	4.4.	User Variables
	4.5.	Layer Definition
	4.6.	Options

	Menu "Objects"
	Select
	Insert
	Text Objects
	Rectangles
	Ellipse
	Lines
	Pictures
	Barcode Objects
	Tables
	Formatted Text
	Chart Objects
	HTML formatted text
	Arrange
	Group
	Assign to Layer
	Copy to Layer
	Properties
	Edit Position Dialog
	Appearance Condition
	Common Appearance Condition
	Name
	Object List
	Linking Objects

	View
	Options
	Appendix
	Index

